Maverick ET-732 Piece of Junk! (UPDATE) New one works fine.

Discussion in 'General Discussion' started by fwismoker, Apr 20, 2013.

  1. fwismoker

    fwismoker Master of the Pit

    Didn't think i'd get mine today but i did.  The dang transmitter power button doesn't work and when i put the batteries in it won't do anything but show all the symbols lit up.   What the heck is going on???  The receiver seems to work but it doesn't do much good w/ out the transmitter!  Please Help....ugh
     
  2. geerock

    geerock Master of the Pit SMF Premier Member

    Are you holding it down for a few seconds and then releasing? And how about the 'ol check batteries are installed correctly?
     
  3. bearcarver

    bearcarver Smoking Guru OTBS Member

    Yup---Could be the "Hold me down awhile" trick.

    I had that problem at first.

    Bear
     
  4. fwismoker

    fwismoker Master of the Pit

    yes and yes...i'm pretty confident at this point i got a bad unit.  If i take out the batteries and put them back in the F symbol shows up but won't do anything else.  I take the batteries out and put them in again all the symbols will show up and it's frozen.
     
  5. s2k9k

    s2k9k AMNPS Test Group

    Yep you gotta hold the button for about five seconds and you have to turn on the receiver first.

    Mines in my smoker right now right next to a nice thick NY Strip and is working just fine so I don't think it's a "piece of junk"!
     
  6. geerock

    geerock Master of the Pit SMF Premier Member

    Remove batteries from both units. Reinstall. Turn on receiver and within 5 seconds press and hold transmitter power button. She should fire up. If not then the F code on the screen is a message from the chinese telling you.....well......I'll let you figure it out.
     
  7. fwismoker

    fwismoker Master of the Pit

    Well Dave i'm jealous of the steak and that your Maverick works..lol because my transmitter is bad. I'm not technologically challenged and it's a bad one for sure.  I suppose i have to call Maverick up on Monday.  Ugh
     
  8. s2k9k

    s2k9k AMNPS Test Group

    Just call Todd, he will take care of it!
     
  9. Call maverick, excellent customer service. My first unit stopped beeping with the alarm they sent me a whole new set.
     
  10. fwismoker

    fwismoker Master of the Pit

    After repeating the steps and taking the batteries out the food temp says "LLL"    Is this thing making progress
     
  11. fwismoker

    fwismoker Master of the Pit

    Yep them or Todd...oh well, i suppose there's always bad units of a good product.   I know it's not the probes because i changed them out and it's the same. 
     
  12. mr t 59874

    mr t 59874 Master of the Pit SMF Premier Member

    Sometimes mine will read HHH or LLL.  Remove the jack and reinsert insuring it's in all the way.
     
  13. fwismoker

    fwismoker Master of the Pit

    Yes thank you, i know what you mean. I pulled it out half way and it reads HHH and re insert it all the way it's back to LLL.  Most likely a bad jack. 
     
  14. mr t 59874

    mr t 59874 Master of the Pit SMF Premier Member

    Okay, Just keep working it by twisting and pushing.  Could be as it is new that there is a film on the connectors and it is not making a good connection as of yet.  Hopefully in time it will work.
     
  15. fwismoker

    fwismoker Master of the Pit

    10-4... It is what it is but i won't let it stop my bbq...that works fine. lol
     
  16. pops6927

    pops6927 Smoking Guru Staff Member Moderator Group Lead OTBS Member SMF Premier Member

    Last edited: Apr 21, 2013
  17. fwismoker

    fwismoker Master of the Pit

    Just took your advice and unfortunately the food temp still reads  LLL.  Thank you though... i looked up the trouble shooting guide and it says the internal temp probe is shorted out.  I just got a lemon is all.  I'll get it sent back and hopefully get a good unit. 
     
  18. mhchops

    mhchops Smoke Blower

    Get wit Todd he will more than likely send you a replacement or something. I've had my Maverick et732 for a few months now and used it many times since don't know how ive done without it

    Mhchops
     
  19. tjohnson

    tjohnson Smoking Guru Staff Member Moderator Insider OTBS Member SMF Premier Member

    If you got it from me, send it back and I'll send a new one out

    Not worth the brain damage you're going thru + you'll never trust it in the future

    Usually LLL or HHH is an error code for a probe that's not seated all the way

    Can also be a bad probe

    Did you swap probes yet?

    Give me a buzz in the morning at (952)736-7678
     

    Todd
     
  20. fwismoker

    fwismoker Master of the Pit

    Thanks Todd, and yes i did order it from you.   The first thing i did was swap the probes out to make sure it wasn't the food probe.   The trouble shooting said it was a shorted out (internal probe)...it's seated good, actually that's the first thing i checked.   I'll give you a shout tomorrow. 
     

Share This Page