Maverick ET-732 DOA?

Discussion in 'Meat Thermometers' started by robertwhite, Oct 5, 2013.

  1. robertwhite

    robertwhite Fire Starter

    TN
    So I got a ET-732 from Todd and I go to set it up for use tomorrow. Read the instructions, OK, no big deal. Install the batteries in order to to a boiling water calibration test.

    Turn the receiver on, go to turn the transmitter on/off and I get nothing. It will neither turn off, nor re-sync.

    All it comes up with is either all 8's (888) and all the various symbols show up, or just 88 or the 3 dashes (- - -) in no particular order.

    Pull the batteries, install different ones, same thing.

    Can't turn it off, can't get any reading whatsoever in the boiling water test, nothing, nada.

    Is it DOA? (not really going to be a happy camper if it is, as I bought it to replace a Taylor unit that actually works)
     
  2. c farmer

    c farmer Smoking Guru Staff Member Moderator OTBS Member SMF Premier Member

    Get ahold of Todd.

    He will know.
     
  3. Well that certainly doesn't sound good. I have one of those and sometimes I get an error message. But once I turn it off it comes back on working properly. Maybe check the input connections of the probes into the unit. Sorry to here about your problem.
     
  4. robertwhite

    robertwhite Fire Starter

    TN
    Didn't really want to bother him on a weekend, so I figured at least this way I would know if I am possibly doing something wrong.
     
  5. cmayna

    cmayna Master of the Pit OTBS Member SMF Premier Member

    Not much good for the weekend, but if necessary contact Maverick on Monday.
     
  6. smokenado

    smokenado Smoke Blower

    How far did the probe go into the water? Wonder if the probe got wet inside is what I'm getting at.
     
  7. robertwhite

    robertwhite Fire Starter

    TN
    Only an inch or so of the tip was in the water. I am not new to smoking and have a fairly good grasp on the whole process. Thanks anyways.
     
  8. kathrynn

    kathrynn Smoking Guru OTBS Member

    You need to turn on the wireless one before the one for the Smoker.  The portable one will not read unless you do them that way.  Also..make sure the probe ends are firmly inside the proper hole on the monitor for the smoker.  I learned the hard way with this.  Got the 8's...and hadnt pushed the probe all the way in the unit.

    Kat
     
    Last edited: Oct 7, 2013
  9. cmayna

    cmayna Master of the Pit OTBS Member SMF Premier Member

    +1   I also learned this the hard way
     
    Last edited: Oct 8, 2013
  10. robertwhite

    robertwhite Fire Starter

    TN
    Did all of that.

    No go.

    Besides that, why wouldn't the transmitter even turn on or off?
     
    Last edited: Oct 7, 2013
  11. kathrynn

    kathrynn Smoking Guru OTBS Member

    All I know is to check the batteries....had mine backwards. Hold the button for several seconds and mine worked. Check back with Todd.

    Kat
     
  12. smokenado

    smokenado Smoke Blower

    Yes you do have to hold the power button down for a long time before it comes on.
     
  13. jckdanls 07

    jckdanls 07 Master of the Pit Group Lead OTBS Member

    Send Todd a PM or an email.... no sense in trying to talk yourself out of the Mavs... they really are pretty descent units.... may I also suggest you get some heat shrink tubing and a little hi temp silicone and seal the probes up at the connection....
     
  14. robertwhite

    robertwhite Fire Starter

    TN
    If I could get Todd to reply to my email, maybe I could get it straightened out.

    The cardboard box was pretty beat up when it arrived. I'm starting to wonder if that has anything to do with the unit not working.
     
    Last edited: Oct 8, 2013
  15. kathrynn

    kathrynn Smoking Guru OTBS Member

    give Todd a chance.  He posted on the General Membership that his business is moving to a bigger location.  He will trust us.  He is the best so far as customer service goes.  FWIsmoker had the same issue as you.  I dont know where that thread is but you could go to his profile and search the thread and see how things got fixed.

    Kat
     
  16. robertwhite

    robertwhite Fire Starter

    TN
    How long ago did he post that info?

    I have tried email with no response and also just now called the number listed on his website. Got no answer and the voice mailbox is not set up to take messages.

    Pretty much everybody checks their email via computer or phone at least once a day, (especially if you run a web based business) so that's a pretty lame excuse. A simple, I am in the process of moving, please give me a few days to get back to you, would not be asking too much.
     
  17. cmayna

    cmayna Master of the Pit OTBS Member SMF Premier Member

    As I had suggested earlier, contact Maverick directly.
     
  18. kathrynn

    kathrynn Smoking Guru OTBS Member

    He is moving now.  Was moving over the weekend.

    Kat
     
  19. tjohnson

    tjohnson Smoking Guru Staff Member Moderator Insider OTBS Member SMF Premier Member

    I replied to your message from my phone last night

    Send it back to me and I'll replace it

    In-fact, I'll send a replacement today with a return label

    You send your defective unit back when you receive the new one

    Sorry for the inconvenience!

    We moved into a larger warehouse, and still trying to find stuff

    QWEST promised they would have my phone and internet connected, and I'm still waiting....IMAGINE THAT!

    They disconnected the phone at my old warehouse and it's not working at the new one

    You can always contact me on my cell at (952)412-0484

    I have internet access thru my Hot Spot & my email works

    Todd
     
    Last edited: Oct 8, 2013
  20. robertwhite

    robertwhite Fire Starter

    TN
    Hey Todd,

    Didn't get the message you sent.

    I understand the complications of moving, just didn't know when you were moving and couldn't find the post.

    I have received your emails from a little while ago and would like to thank you for the handling of this matter.

    Sorry for the confusion/issues on both ends. Just was frustrating having to go back and forth 75yds constantly while smoking the other day for 8 hrs. It was supposed to rain so I had moved the smoker down to the barn. The Maverick would have come in very handy as my Taylor has no grill temp probe.

    If the new one works as it should, all will be well in smoking land once again!
     

Share This Page