Troubleshoot Foodsaver

  • Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.
SMF is reader-supported. When you buy through links on our site, we may earn an affiliate commission.

Smokin Okie

Master of the Pit
Original poster
★ Lifetime Premier ★
Jun 27, 2018
1,758
1,563
Oklahoma City
Tried to vac seal a ribeye with my Foodsaver yesterday. It vacuums but won't seal. It reaches the high pitched volume level when it normally shuts down then seals the bag. But it just keeps going.

Just last week I started using the jar attachment and I used a storage container. First time to use either. I expected it to cutoff when it fully vacced the jar/container but it doesn't do that. Is that normal ?

Is there something I need to do in the transition back to bagging from jars/containers ?

BTW, if the only task is sealing a bag, it works just fine. Its vaccing and then sealing is where it fails.
 
Last edited:
What model is it ?
I have a Game Saver Deluxe Plus . I've had it several years . It's a great machine .
As far as using the containers , they can take a long time to pull all the air out . Sometimes I have to hold down on the lid to make a good seal .

Have you tried different bags ? Just to make sure you don't have a bad bag or a leak .

All that said , there is a valve on the right front corner ( in the bottom ) that lets air escape the vacuum cycle , then closes to hold the vacuum in the bag when sealing . If liquid gets sucked on the valve surface , it won't hold the vacuum and start the sealing cycle .
I had to fix mine once a few years ago , and it's doing it again . If I get it opened up today I'll get some pics .
That's where I would start .
 
I have model V2244.

Yes, I've tried different bags.

Sounds like that may be my problem.
 
  • Like
Reactions: chopsaw
Sounds like that may be my problem.
Maybe re try the canister . Make sure the lid is sealing and give it some time . You know the sounds of the drawing , or just running .
I've been needing to look at mine for awhile . Been using the Ink bird as a back up .
There are some great videos out there to look at .
That valve is just a port with a rubber pad on an arm . If something gets on the pad it leaks . If you get into it and have a question , holler .
 
The only experience I've had that's similar to yours SO with our V4980 model food saver. Is when it's struggling to complete its vacuum. Usually because of some weird air void in the way I've put whatever in the bag. To remedy this - I leave the bag in the machine, and hit the cancel button. Then I just restart the process. Other than that the only maintenance is pulling out the drawer and cleaning the metal heat strips, rubber gasket and the catch basin. It's been running flawlessly for a number of years.

Chris
 
  • Like
Reactions: chopsaw
Mine worked fine until I used it with the jar attachment. And it vacuumed the jars cause the lid was on tight. I could pick up the jar by just holding the edge of the lid. And I've had trouble getting the lids off.

I watched the tube closely for any liquid traveling up the tube and never saw anything.

It just never told me that it was done. I expected it to automatically shut off.

Then I go back to a bag yesterday and it will do everything but seal.

I just spent $40 on the canister and the jar attachment, I'd like to salvage this unit.

I have an Inkbird as a backup, anyone know if my Foodsaver jar attachment will work with Inkbird ?
 
Went through two. cabelas brand one was warranty the the second I just trashed waiting till I find a good chamber vac
 
I've had a similar issue with mine (have 2).
I concluded there was a leak in the bag somewhere, and the vacuum operation was never happy with that so it kept trying and never completed it's cycle.
Wrinkled bags from a roll are bad.
 
I have an Inkbird as a backup, anyone know if my Foodsaver jar attachment will work with Inkbird ?
Yes . Steve H Steve H opened my eyes to using it . Just stick the suction cup end over the canister and push the button .

I just got done putting mine back together . The valve was dirty . I cleaned it , but it still won't auto seal , but now it will let me use the manual seal . Before it would leak down if I tried that . So that tells me the gaskets are likely bad on the lid / body .
Mine looks like this . The models that look like this should be about the same .
1688648741062.png
5 screws hold the bottom on . 2 are exposed and 3 are hidden under the rubber feet .

20230706_073547.jpg
Opened up . The valve is on the right ( when upside down ) It's controlled by the locking lever .
20230706_073631.jpg
Close up . You can see some junk got sucked through the valve .
20230706_073654.jpg
20230706_073658.jpg
Pulled the valve open .
20230706_073705.jpg
2 screws hold the valve in place . I removed it and washed the junk off . Cleaned the mating surface .
20230706_074538.jpg
20230706_074540.jpg
That foot just pulls out . The screws in the back are deep in there .
20230706_074902.jpg
20230706_074913.jpg
Before it wouldn't let me manual seal , because it would leak off . Now I can , so I know the valve was dirty . This is probably 75% of failure with these . The other is the sealing gaskets at the lid . My opinion of course .
20230706_075401.jpg

It just never told me that it was done. I expected it to automatically shut off.
When doing the jars , listen for the lid to pop . Like said , it takes awhile to get the air out sometimes , but mine usually stops on it's own .
 
While mine is different I've got to believe the basic parts are similar & probably the procedure as well.
Thanks Rich!
 
  • Like
Reactions: chopsaw
Matt , I would bet they are too . Simple system . I would normally clean the pump while I had it open , but didn't this time .
They're good sealers that have this happen , and people decide they're junk .
I bet mine is 10 years old .
Are you having issues with yours ?
 
I have to push down on the lid to get mine to work most of the time. I've never tried the jar attachment. It's probably time for me to get a new one, too, but I may try that repair as well if it gets worse. I store it with the lock on all the time. I never thought of that causing the gasket to wear out, but I guess it would.
 
  • Like
Reactions: Smokin Okie
I had to empty out the tray inside that had filled up with liquid from something I did. First time I'd had to do it in the darn near 20 years I've owned this Food saver.
 
  • Like
Reactions: chopsaw
SmokingMeatForums.com is reader supported and as an Amazon Associate, we may earn commissions from qualifying purchases.
Clicky