My 6 mounth old MES died

  • Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.
SMF is reader-supported. When you buy through links on our site, we may earn an affiliate commission.


Smoking Fanatic
Original poster
~~Well my 6 month old MES 30 (20070910) died last week. I set the temp and time for a warm up and found it only ran a few minutes. After a short investigation with a Fluke tester I found the receptacle was hot but the MES cord was not. I thought it might be the controller so I swapped it out with a new one I had on hand. I checked the inspection plate at the element and found nothing obvious. . No joy. I called MES and they said they would give me a new cabinet for the fist year. From this I deduce they know they have a problem. If they do give me a new cabinet I should be happy.They won't get my new controller as I replaced with the original. If I have to remove the back plate what should I be looking for other than the apparent problems? I must add that the pork tender loins ended up great. Since it was cold I cold smoked them for 2 hours. Then cooked them in the oven for about 1.5 hours .I had sliced them in to 1/4 inch thick pieces marinated them in Worcester and soy sauce with a lot of my rib rub before cooking I put them on schewers and then cooked the pig on a stick. Thanks for the receipt Jeff. I will cook this again when I find them on sale. JTED
Hello jted.  I would stop checking.  Company said they would replace.  Most companies will not honor guarantees if they see that you have removed plates or parts.  The screw heads are painted and as soon as a screwdriver touches them the paint comes off.  I'd try to touch up the screws removed and leave it alone.  I know it ain't strictly kosher but...  Go for the replacement.  Good luck.

Did the display light up..... Can you set the time and/or temp.... does the clock work..... More info would help....

Dave The ready light came on I set the time and Temp. The display worked so far as to let me set the temp and start the unit by setting the cook time. The unit heated for several minutes long enough to put some heat in the box ,several minutes worth. I do not plan to trouble shoot any farther than I have..  Jted 
Sounds like it could be burned connector to the heating element.  There is a relatively standard Chinese solenoid in the bottom of my MES 40 that went out.  Mine died in the ON position and burned anything you put in the unit, but it could die in the OFF position just as easily with results as you described.  In mine the heater was on any time the unit was plugged into the wall, even if the controller was unplugged from the unit entirely. There are other possible problems, but either the heater connector or the solenoid are the most likely. Repair is a pain and mine was out of warranty so I fixed it, ordering a half dozen of the new solenoids to get one.   Still only cost about $25 including shipping.  However, if you can return that thing, that is what you should do. 
~~I spoke to customer service and they plan on replacing the smoker after I return the ID data plate W/SS#'s They also wanted the power cord. I asked her how much of it and she said the plug would be fine. I hope they send me the same model as I have some spares (heating element and controller). By the way mine was out of warranty by 3 months is reader supported and as an Amazon Associate, we may earn commissions from qualifying purchases.

Latest posts

Hot Threads