Possessed Fireboard 2

  • Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.
SMF is reader-supported. When you buy through links on our site, we may earn an affiliate commission.

SGMan

Smoke Blower
Original poster
Mar 12, 2019
140
110
P-Town Virginia
I recently got sick of the terrible controls and connectivity issues with my MBGF 560, so I took the plunge and jumped on the Fireboard2 bandwagon.

Excited to finally use this thing, I ran into a couple of small snags initially but after that hump was cleared it was smooth sailing.

FFWD 2 days later - I fire it up and plug in the temp probe and its reading 700 degrees over the true temp. Change ports - same result. Add another probe - same behavior.
As far as I know, nothing had changed from its maiden cook until today when I had to reestablish connectivity with my OG controls.

Has anyone else had this happen with their FB2?
 
While I don't have the same board that you do, I did toast some probes by getting the wires too hot while reverse searing some steaks. So I do know that you can kill the probes and that they'll give you all kinds of weird readings. In my case, the smoker was at about 220 degrees, but the probes read something over 750 degrees.

Have you checked with the manufacturer? That would be my first choice in getting help with something like this. Hope you get it figured out.
 
  • Like
Reactions: SecondHandSmoker
Yeah, that should be my next step.


I just found it odd that the ambient probe was the one doing this initially.
I plugged in (the recently used) meat probe and same symptoms.
Pulled the ambient probe from my (last working) Auber PID and same thing...

Ill try a brand new probe from the packaging (and then) contact the manufacturer. Im sure they have seen this more than once :)
Thanks!
 
  • Like
Reactions: dow
I know Ted and the guys at fireboard will get you squared away if the new prob doesn't resolve the issue
 
  • Like
Reactions: SGMan
I have a FireBoard 2, sans controls - no fan - just temperature indication. I've not yet experienced what you described OP.
 
SmokingMeatForums.com is reader supported and as an Amazon Associate, we may earn commissions from qualifying purchases.

Hot Threads

Clicky