Mes30 no heat after replacing element

  • Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.
SMF is reader-supported. When you buy through links on our site, we may earn an affiliate commission.


Original poster
Nov 29, 2007
Hello group
I just replaced my heating element on my mes 30 heating element after i had a water spill that caused an arc. The old heating element showed a nice size gash from the arc, so i thought i had the problem solved when i replaced it, but no heat. I have not replaced the spade connectors yet which is next on my list, but iwanted to ask how to check if power is being sent from the control unit with my Digital Multi Meter (fluke meter)
Thanks in advance for the help

The wire that comes into the back inspection hole, from the lower right side, is the hot lead...  If it has power when the control panel says "heat", you are good to go... If not, something could have "blown" in the controls which are in the bottom of the unit, lower left side of the floor....    replace the spade lugs and use an anti corrosion grease, that's designed for electrical, to stop any corrosion, or solder the wires to the element lugs...  That's the surest way to eliminate future problems....

You can always add a controller to the heating element and bypass the original controls....  if all else fails... 
Hello everyone, after a long stint of not using this smoker (gave up on it for a while), I want to try and get her going again. I replaced the spade connections on the back but I'm still not getting power. I drilled out the bottom and took a look at the connections there, and I'm finding no corrosion nor evidence of damage. However, what else and how can I test with my volt/ohm meter? I turned the unit and it said heating, but I got no reading on my meter testing DC across both connections? Is it possible the control unit may have gone kaput or the connection?
Below is a pic of the connection to the two modular connection that didnt seem right to me(not burned but had a bulge)
Any input on that and testing properly is much appreciated


  • IMG_8071.JPG
    179 KB · Views: 34
  • IMG_8072.JPG
    215.5 KB · Views: 32
Test the leads, going to the heating element, to the chassis... lower right wire should be hot.. the other wire should have continuity to the chassis as it is the common / ground wire...
If all else fails, you can get a controller on Amazon for about $35...

or, you can get a SCR for about $15.... You adjust the wattage to control the temperature manually... like the flame on a gas range... no on-off... always on... I use something similar... a dimmer switch... I like the fact the element never turns off...

Or, Auber has a wide range of EXOTIC controllers.. is reader supported and as an Amazon Associate, we may earn commissions from qualifying purchases.

Latest posts

Hot Threads