1. Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.

Forum Software Keeps Changing My Links

Discussion in 'Bugs, Glitches and Miscellaneous Forum Problems' started by johnmeyer, Mar 19, 2019.

  1. johnmeyer

    johnmeyer Master of the Pit

    I posted a review. Here is a link to that review:

    https://www.smokingmeatforums.com/threads/review-camp-chef-pizza-oven-accessory.285382/

    I provided a link to Amazon in this review. However, this forum's software removed that link and instead inserted a link to the manufacturer's site ("Camp Chef").

    This was the URL I was trying to assign:



    Here is the text to which I wanted to assign this URL:

    Camp Chef Italia Artisan Pizza Oven Accessory

    I also assigned this URL to a picture. I was going to post that picture here, but it does not appear in my "media gallery," so that's another bug I'm reporting.

    The strange thing is that this all worked just fine shortly after I initially posted because I always test links before I go on to something else.

    I spent a lot of time on this review and it is disappointing to have these links not working.

    [edit]I just posted this and noted that the software has completely screwed things up again. There is no huge gap in what I wrote, and the links are all wrong. I'm not going to spend any time trying to fix things for the simple reason that I can't fix something that the forum software is going to break again. The problem in this post is a different one from those I am reporting with the other post. In this case the software changed the link, which was just a cut/paste of the URL, into a media link.

    [edit#2]I just noted that the Amazon link in my initial review is now working. I have no idea what is going on.
     
    Last edited: Mar 19, 2019
  2. motocrash

    motocrash Master of the Pit OTBS Member

    John,as I'm sure you remember a while back,the site made the change to the advertising.You seem to be a real computer savvy guy,way more so than I.I believe this deal "at the crossroads" is what is messing with your posts.What I mean is the links are being changed for Etailing purposes that are being tracked and funding the site.
    Smelling what I'm stepping in?
     
  3. daveomak

    daveomak Epic Pitmaster OTBS Member SMF Premier Member

    .....
     
  4. bmudd14474

    bmudd14474 Legendary Pitmaster Staff Member Administrator Group Lead OTBS Member ★ Lifetime Premier ★

    John the issue you are having is not with SMF. Its with the Amazon Plugin that displays that when you use their links. It happens from time to time. The way I get around it is I upload a picture of the item then use the link button Screenshot_8.png
    and put the url in there. This way i am not dependent on Amazons plugin everytime. Seems like a pain but we dont control their stuff.
     
    tardissmoker and indaswamp like this.
  5. indaswamp

    indaswamp Master of the Pit OTBS Member

    That's how I do it too Bmudd
     
  6. motocrash

    motocrash Master of the Pit OTBS Member

    :emoji_thinking: So I can take my tin foil hat off?:emoji_alien::emoji_joy:
     
  7. johnmeyer

    johnmeyer Master of the Pit

    Thanks for the replies everyone. I knew the Camp Chef link was being inserted in order to support advertisers. I am totally cool with that and don't mind that change. What I did mind was having the Amazon link disappear, then reappear, then go away again.

    Given some of the ideas people have given me, I'll go back and try a few things (like downloading the pic and then uploading it to my media stash) and see if I can't get the link to stick.

    [edit]I put the words "Camp Chef" outside the link. I downloaded the image and then uploaded it to the site, rather than use an image URL. At the moment, everything seems to work. We'll see if the forum software makes changes in the next hour or so.
     
    Last edited: Mar 19, 2019
    bmudd14474 likes this.
  8. bmudd14474

    bmudd14474 Legendary Pitmaster Staff Member Administrator Group Lead OTBS Member ★ Lifetime Premier ★

    This is why I started to do it this way because the Amazon Plugin was causing me issues.

    Let me know if you have other issues.