Pelletheads

Discussion in 'Pellet Smokers' started by greg1, Sep 9, 2017.

  1. greg1

    greg1 Fire Starter

    Anyone know what's up with the pelletheads website. Was up and working earlier in the week but now I get an error message when I try to view it. If this doesn't belong in the section feel free to move or delete.
     
  2. darwin101

    darwin101 Meat Mopper

    The message says "Server currently undergoing maintenance."
     
  3. bregent

    bregent Smoking Fanatic

    The site was acquired by a new owner a month ago, after the previous owner and founder passed away earlier this year. The new owner pledged to keep the site content as originally intended, and do some technical enhancements which were sorely needed. During the past few weeks, the site became unstable with frequent 505 errors - possibly as a result of the new owner re-arranging some forums and doing other tweaks. Then, about 5 days ago the site went down and displaying the error you see now. Ominously, the last post I read minutes before the site went down was a member saying something like 'this is the end'.

    So I can only speculate what's going on. Could just be a technical issue that is over the head of the new owner. Maybe he's doing a major upgrade. Or maybe he realized it's more work than expected and it's offline for good. There are some newly appointed PH forum moderators that are also members of this forum - so maybe they'll chime in soon with more details.  
     
  4. Website still down. I hope it comes back. Lots of good info there.
     
  5. gr8day

    gr8day Smoke Blower

    Bentley the moderator from pellet heads has started a new site called pelletfan.com  
     
    Last edited: Sep 12, 2017
  6. mowin

    mowin Master of the Pit

    Just registered. Waiting for approval.
     
  7. lowslowfoshow

    lowslowfoshow Newbie

    Nice!
     
  8. Has anyone tried to register at pelletfan.com?  I keep trying but even though I type the verification image properly, it says it's wrong.  I have tried upercase, lowercase and everywhere between.
     
  9. lowslowfoshow

    lowslowfoshow Newbie

    The captcha should be: KBVHBK
     
  10. Not sure why it was kicking me out before, but working ok now.  Waiting on Admin approval.  
     

Share This Page