• Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.

HELP!! No heat

tsapp

Newbie
21
13
Joined Oct 28, 2020
I have an MES 30 that had no heat I found a bad spot on the element, so I ordered a new one and replaced it, still have no heat the wires look great, the controller acts like it should be good , power light comes on set the temp and time and the red heating light comes on, the LED light works, I disconnected and reconnected all 3 plugs for the light and it beeps when it gets power, but still no heat. Can anyone help? I am suppossed to smoke a brisket for my neighbor tomorrow who is 86 yrs old.
 

dr k

Master of the Pit
OTBS Member
2,680
577
Joined Mar 22, 2013
After entering the temp then time and set I can hear the relay in the bottom click and power green, heating red leds are on but no heat. I unplugged the smoker and had to cut an access in the back of the smoker where the round dime thermal switch is inside the smoker with a dremel cut off wheel. One wire was corroded off one of the male spades on the switch so I just bypassed it with a wire nut. If the wires look good the switch maybe bad and after the wires are disconnected from the thermal switch you can ohm it for continuity and the switch should be closed for current to flow through. Some smokers have a thermal switch access like the element.
 

Latest posts

Hot Threads

Top Bottom
  AdBlock Detected

We noticed that you're using an ad-blocker, which could block some critical website features. For the best possible site experience please take a moment to disable your AdBlocker.