• Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.

Bradley E1 message/flashing and beeping...

strtbobber

Newbie
11
10
Joined Nov 12, 2013
Hello all, I was given a Bradley BTDS76P today.  I've never used one, as I have a smoke house in the yard.  I cleaned it up and plugged it in and the E1 message displayed along with a beep.  I'm able to turn on the oven and the smoker switches but nothing else will operate.  My apologies if this is an old topic, I did not read.  I went straight to whining here........


Thanks for any help!  
 

strtbobber

Newbie
11
10
Joined Nov 12, 2013
Well, thank you to whoever would have replied.  After a bit of reading on the internet, I flipped the sensor cable end for end and it works great!  Woohoo.  I'm pumped!!
 

donegotfat

Meat Mopper
192
121
Joined Oct 16, 2016
Sorry no one was able to help in time. The great news is you found a fix and it sounds like your a happy camper now,

Good luck.

I know there are folks here from all parts, but I am guessing you caught many of us at dinner
 

strtbobber

Newbie
11
10
Joined Nov 12, 2013
Hey, no worries! I was impatient and posted the thread in case I had trouble getting it working. All is good and yes, I am a happy camper. Chuck roast tomorrow after a morning Whitetail hunt. Thanks for the reply!!
 

Latest posts

Hot Threads

Top Bottom
  AdBlock Detected

We noticed that you're using an ad-blocker, which could block some critical website features. For the best possible site experience please take a moment to disable your AdBlocker.