Vacmaster Pro 110 Vacuuming issues

Discussion in 'Slicers, Grinders, Tools, Equipment' started by kingt36, Apr 26, 2014.

  1. kingt36

    kingt36 Meat Mopper

    We bought a Vacmaster Pro 110 off of Amazon a few months back. It has been working fine, however today we are trying to vacuum seal some bacon and it won't work right. It is staying on the vacuum part of the operation for a very long time, then when it finally switches to "seal" it loses some of the vacuum. 

    Anyone else have this problem? If so, how did you resolve it? I tried calling ARY, however they are closed on the weekend apparently.
     
    Last edited: Apr 26, 2014
  2. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Be sure both locking tabs, for the lid, are locked in position..... Two hands at the same time pushing down.... listen for the clicks.....
     
  3. kingt36

    kingt36 Meat Mopper

    I think that is what the problem was. My wife wasn't doing that at first, I don't think. Later on I did it and it worked fine.
     

Share This Page