Thermoworks Signals displaying Celsius won't switch back to Fahrenheit

  • Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.
SMF is reader-supported. When you buy through links on our site, we may earn an affiliate commission.

Smokin Okie

Master of the Pit
Original poster
★ Lifetime Premier ★
Jun 27, 2018
1,659
1,455
Oklahoma City
Somehow, it started to display in Celsius and I can not get it to switch back to Fahrenheit.

I used it Friday to season a new smoker. I kept it connected to electrical outlet all night to make sure it was fully charged for a rib cook on Saturday.

I start it up on Saturday and its reading Celsius. So I follow instructions on switching. I disconnect from power. Start the unit with a 6 second count. It switches to Fahrenheit. I then shut down the unit with a 3 second count. I restart the unit and its displaying Fahrenheit but a few minutes later it will switch to Celsius.

What's really strange is my T-Works phone app displays Fahrenheit.

Anyone else had this problem ?
 
I took a look at mine . I can change it on my phone , but not on the unit .
 
Sounds like it may be switching back to Celsius when it takes to the cloud and/or phone app. I'd dig around in the app menus to see if there are separate settings for the app and device.
 
Thermoworks solved the problem. Somehow I'd changed the " Device Settings " to Celsius. In case anyone else has this problem or are interested , here's the email I got from TW

For your Signals, there are three locations where you can change to display units.

On the Signals it self.

In the ThermoWorks app under your user settings.

In the ThermoWorks App under the device settings.


My guess, is that in ether your user settings or the device setting you have the ThermoWorks app configured for Celsius.

Check User settings

Open your ThermoWorks App.

Click on the three horizontal lines in the top left corner of the app.

Select the "User settings".

Under the User Settings ensure that the the preferred Unit field is configured correctly.

Exit the User Settings.


Check the device settings.

Open the ThermoWork App.

From the Home/Device screen, select your Signals.

In the Signals screen, click on the "Settings" button.

From the Settings screen ensure the the Display Units field is configured correctly.
 
  • Like
Reactions: MJB05615
SmokingMeatForums.com is reader supported and as an Amazon Associate, we may earn commissions from qualifying purchases.
Clicky