Pellet overload -PitBoss

  • Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.

Wm.compton68

Newbie
Original poster
Dec 25, 2019
2
0
The heating elements on these pit boss smokers must burn out easily,
Starts out working just fine, After an hour, heat stops and the augger fills the pit full of pellets? Anyone having same experience?
 

TNJAKE

Legendary Pitmaster
OTBS Member
SMF Premier Member
Nov 26, 2019
9,913
13,512
Ridgetop Tennessee
What temps you running? P setting? Weather conditions? Fire pot empty of ash before you started? Pellets dry?

If its lighting then the rod is fine. It actually only stays on at start up for about 4min then it's off for the rest of the cook. As far as how long the rod lasts....I replaced mine after about 350 cooks.
 
  • Like
Reactions: jcam222

JWFokker

Smoking Fanatic
Mar 5, 2019
513
173
Sounds like the flame went out. Could be low ambient temp or too much ash in the firepot. Clean your cooker out and try again. If it's really cold you may need to run a lower p setting to keep it burning.
 

Wm.compton68

Newbie
Original poster
Thread starter
Dec 25, 2019
2
0
What temps you running? P setting? Weather conditions? Fire pot empty of ash before you started? Pellets dry?

If its lighting then the rod is fine. It actually only stays on at start up for about 4min then it's off for the rest of the cook. As far as how long the rod lasts....I replaced mine after about 350 cooks.
Second attempt after cleanup, worked perfect!
 

Latest posts

Hot Threads