master forge smoker loosing heat

Discussion in 'Roll Call' started by bigfoot73, Mar 5, 2012.

  1. bigfoot73

    bigfoot73 Newbie

    I have a problem with my master forge not maintaining heat. I have used it 7 times and the last two times I preheated it with the water pan or the smoker pan. The heat was at 250 but as soon as I placed the water pan and smoker pan in the temp went down to 180 and never went higher that 195. The flame was on high and is a good color blue. any suggestions?
     
  2. smokinal

    smokinal Smoking Guru Staff Member Moderator OTBS Member ★ Lifetime Premier ★

    Welcome to SMF!

    Would you update your profile info to include your location. Thanks!

    If you post your questions under propane smokers you should get more responses.
     
  3. mballi3011

    mballi3011 Smoking Guru OTBS Member SMF Premier Member

    [​IMG]

    First off welcome to SMF. Now the problem with your smoker heating up sounds to me like you might have a joint loose in in gas line. If it is the slightest bit loose it will only let the flame go so high. If not maybe make sure you have the right type off gas propane or natural. I'm just grasping at strays here so. I would also recommend that you call he manufactor and see what they have to say.
     
  4. scarbelly

    scarbelly Smoking Guru OTBS Member

    Hello and [​IMG]to SMF - I think Marc has you pointed in the right direction on the propane issue but one other thing you might do is to totally disconnect the hose from both ends and reinstall it.  Good luck and good smoking 
     
  5. The Master Forge also has a safety built into the regulator. If you open the gas on the bottle too fast, the regulator will shut down the flow. Close the bottle off, unhook the regulator, hook it back up and then open the gas bottle slowly and see if that helps. This happened to me a couple of times as well.
     
  6. bigfoot73

    bigfoot73 Newbie

    I have tried this and my heat was still low. I even switched tanks but the same thing.
     
  7. sprky

    sprky Master of the Pit OTBS Member

    I have the master forge as well and have no problem getting into the 300 range. It sounds like your safety has activated. check ALL the connections on the gas line with a soap solution. if you see any bubbles you have a leak. You could also have a bad regulator. If after checking all connections and you have no leak call customer service, and talk with them. I have found them to be quite helpful. If ya want/ need more help feel free to pm me. 

    [​IMG]  to SMF. You have come to the right place for smoking info. This site is loaded with great info just use the search bar at top of page to find what you are looking for. If you can't locate the answer just ask folks here are willing to share there knowledge. I suggest you take  the 5 day e-course on smoking its chuck full of great info.Smoking  5-Day e-Course  
     

Share This Page