ET-73 Went crazy

Discussion in 'Meat Thermometers' started by jhubert88, Apr 5, 2008.

  1. jhubert88

    jhubert88 Newbie

    Does anyone know if the meat probe for this thing is not supposed to be submerged in water? I was letting my Apple brine cool down and I wanted to see where the temp was at so I lowered in the meat probe. Part of the cord was in the brine as well. I was fine for awhile then I went to take it out and the temp went into the 300's and stayed. I plugged in the smoker probe into both ports and it reads okay so I know it isn't the unit, seems like the probe is shot or I ruined it when I measured the brine. Has anyone heard of this or had this happen to you?
     
  2. If the probe wiring gets wet, it's done. I'm not sure what replacement probes cost but I know Maverick sells them.
     
  3. walking dude

    walking dude Smoking Guru SMF Premier Member

    yeah.......letting the wire end of the probe in water........you mite be screwed
     
  4. earache_my_eye

    earache_my_eye Smoking Fanatic OTBS Member

    WOW.....I have a cheapie digital probe from Wally world......granted, it only monitors one temp.....but, have had it submerged while cooling summer sausage, and it is still working just fine........???
     
  5. jhubert88

    jhubert88 Newbie

    Thanks for the fast responses. I kind of figured I toasted the probe. I guess I didn't think to check if it was a waterproof before I did that. I hope I can find a replacement probe at a store in town, if not I will probably buy a single probe monitor and send in the probe to Maverick and see if they will replace it. I plan on smoking a turkey on Sunday so this was bad timing.
     

Share This Page