brand new MES 30" heating element fail

Discussion in 'Electric Smokers' started by urahoho, Jan 5, 2012.

  1. urahoho

    urahoho Newbie

    So I have bought two MES 30" 20070910 from Amazon.

    1st one was ordered through Amazon warehouse for 173.  When I opened it up, i noticed the top plastic part of the hinge was broken.  I unwrapped everything and plugged it into a 14 GA extension cord and tried to season it.  Waited 30 mins, the temp inside the MES went from 60 to 50 degrees.  I changed the outlet and tried again.  Waiting an hour, no temperature changed.  Unplugged the extension cord, took the MES into my house, plugged it directly into the wall and try to run the unit, waited a hour, not change in temp.  Returned the unit to Amazon, told them it was defective.

    2nd one was ordered though amazon directly, brand new for $179.  When I opened it up, I notice the plastic on the right front leg was broken. Unpacked everything.... plugged it into a 14 GA extension cord and tried to season it.  Waited 30 mins, the temp inside the MES went from 62 to 56 degrees.  I changed the outlet and tried again.  Waiting an hour, no temperature changed.  Unplugged the extension cord, took the MES into my house, plugged it directly into the wall and try to run the unit, waited a hour, not change in temp.

    I have to contact Amazon again for another return.  Does the MES have heating element problems on arrival?  Any other ways to troubleshoot?  I have also tried different outlets in the house....I just don't believe that both the units have dead heating elements....

    Tempted to pick one up from lowes for $149....any difference between the 20070910 or the 20070511 models?
     
  2. Are you setting both the temperature and timer on your smokers? I've made this mistake not setting both when i first bought mine ...when both are set a red light will appear on the controller. This means the smoker is set correctly and power is being sent to the element.
     
  3. smokinal

    smokinal Smoking Guru Staff Member Moderator OTBS Member ★ Lifetime Premier ★

    He's right it won't start without the timer being set.
     
  4. urahoho

    urahoho Newbie

    .....fail..... you need to set the timer to get heating element to turn on?!?! 

    LOL well I guess I sent back good heating elements back to amazon....they are shipping me a new one today.....

    Although the first 2 were damaged in shipping though.
     
  5. fpnmf

    fpnmf Smoking Guru OTBS Member

    Fl
    The manual sez dont use an extension cord.

    I have a very short cord (surge protector) and the MES wont run off it if some thing else is on the circuit.

      Craig
     
  6. urahoho

    urahoho Newbie

    I read online that people said a extension cord wasn't good, but I bought a 14 gauge heavy duty one (cost me $40), specifically for the smoker.  I did reread the manual, and mine says an extension cord can be used with it if necessary.

    Now making sure other things are plugged in too, I do have other small kitchen appliances plugged into the same circuit.  I was more worried about blowing the circuit.  But I think it is the timer issues.  I never tried setting the temp and timer together, only the temp.

    My new one, hopefully not damaged from shipping will be in next Tuesday. I have 3 racks of ribs in the freezer waiting to be smoked.  I hope it works, so it will be perfect for MLK weekend.

    Thanks for all the advice though.
     
  7. eman

    eman Smoking Guru Staff Member Moderator OTBS Member

    !4 guage is kind of small for the MES.

     i made a 10 gauge cord 15 ' long that works fine.

     BTW, Most of the  time the use of the word heavy duty w/ extention cords is just refering to the insulation , has nothing to do w/ the wire.
     
  8. roller

    roller Smoking Guru SMF Premier Member

    I can confirm that....good luck getting one of the 149.00 from Lowes...
     
  9. urahoho

    urahoho Newbie

    10 gauge. Wow. I would of gotten that but it cost $50.

    I am letting amazon ship me a 3rd one first and pick up the broken second one. If the 3rd one is broken again. I will go to lowes.
     
  10. urahoho

    urahoho Newbie

    10 gauge. Wow. I would of gotten that but it cost $50.

    I am letting amazon ship me a 3rd one first and pick up the broken second one. If the 3rd one is broken again. I will go to lowes.
     
  11. urahoho

    urahoho Newbie

    Phone fail
     
    Last edited: Jan 6, 2012
  12. micker

    micker Fire Starter

    Using an extension cord can prevent you from getting the highest temps out of it (for chicken) plus it can be a fire hazard.  

    The heating elements in the MES draw a lot of power and a lower gauge extension cord can cause a fire. 
     
  13. garyinmd

    garyinmd Meat Mopper SMF Premier Member

    My MES 30 has a 650 watt heating element, I have read where some have a 800 watt.

    650 watts divided by 110v the unit will draw 5.9 amps.

    800 watts divided by 110v the unit will draw 7.27 amps.

    1200 watts in the MES 40, 1200 watts divided by 110v the unit will draw 10.9 amps.

    This does not count the controls but my guess is that would be very minimal on the power usage.

    Gary
     
  14. timsnewatsmokin

    timsnewatsmokin Fire Starter

    Thank you for posting that it helped me because I was just setting the temp, and cussing masterbuilt...lol
     
  15. sb59

    sb59 Smoking Fanatic

    Don't know your smokers amps or your extension cord length but here is a guide. Other appliances on the same circuit have no effect unless you turn them on.
    Extension cord lengthAmperage Required
    0-2 amps2-5 amps5-7 amps7-10 amps10-12 amps12-15 amps
    25 ft.16 ga.16 ga.16 ga.16 ga.14 ga.14 ga.
    50 ft.16 ga.16 ga.16 ga.14 ga.14 ga.12 ga.
    100 ft.16 ga.16 ga.14 ga.12 ga.12 ga.10 ga.
    150 ft.16 ga.14 ga.12 ga.12 ga.10 ga.-
    200 ft.14 ga.14 ga.12 ga.10 ga.--
     

Share This Page