Temp Problem

  • Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.

cecil

Meat Mopper
Original poster
Was smoking some baby backs on the WSM for the fourth(actually did them on the third). Set up the smoker and lit coals as I usually do. The temps ran at 225-250 for an hour before I put the ribs on. After I put them on and was running for a while i noticed the temperature showing on my maverick was at 145 but the lid temp showed 250 and the one I installed at the top grill level was about 230. I trust the Maverick more than I do the other two for the more accurate temps so I opened the vents a little more. I left and went to town to get some ice for the beer and on the way back i was thinking about my temp problem when it hit me. When I got back lifted the lid and i was right about my suspicions. I had in inadvertently laid one of the cold ribs on the Maverick probe. Kicked my self in the rear a few times for being so dumb and continued to smoke the ribs as usual. They came out great as did the chicken, sausage ,pork . and burgers and we all had a great 4th of July BBQ on the third. 

I hope every one had a great and safe 4th.
 

GaryHibbert

Legendary Pitmaster
OTBS Member
★ Lifetime Premier ★
th_HaHa7_ani.gif


Gary
 

gearjammer

Master of the Pit
Apr 6, 2015
1,472
173
Central New York
If you did it, one or more of us has done 

or would have done it sooner or later.

Thanks for letting everyone know that such

things can and will happen.

       Ed