Maverick 732 issue?

Discussion in 'General Discussion' started by olecrosseyes, Oct 4, 2015.

  1. olecrosseyes

    olecrosseyes Meat Mopper SMF Premier Member

    Hey all,

    My maverick 732 of 2 years for the cabinet temp works fine but the food probe shows "LLL".

    Do I have a bad probe?

    Are replacements available?

    How do I know where the issue is?

    Thanks!
     
  2. It's a bad probe.  Replacements can be ordered from the Maverick website.
     
  3. ^^^ what Bama BBQ said.
    The replacement probes are better and longer.
     
    Last edited: Oct 4, 2015
  4. I buy mine from Amazon though
     
  5. olecrosseyes

    olecrosseyes Meat Mopper SMF Premier Member

    What is their proper web site?

    What about one of our sites men, T Johnson, I think his handle is??
     
    Last edited: Oct 4, 2015
  6. chef jimmyj

    chef jimmyj Smoking Guru Staff Member Moderator Group Lead OTBS Member

    Todd... http://www.amazenproducts.com/ Sells them, has good prices and is one of us. BTW... Make sure the mini plug is clean and well seated. This code can happen if the plug is not making contact...JJ
     
  7. olecrosseyes

    olecrosseyes Meat Mopper SMF Premier Member

    Thanks Bama BBQ, PapaDon and Chef JimmyJ!

    Not only was the plug seated but I swapped the plugs side to side to make my conclusion that it was the probe.

    The other 3 probes that I have (by other makers) are of a shorter pin length so they would not work.
     
  8. olecrosseyes

    olecrosseyes Meat Mopper SMF Premier Member

    Well, Todd, I just sent you an order for 2 probes and a 12"pellet smoker. look to see it in a few days, I'm brining a couple of briskets starting tomorrow. (Pastrami in the works)
     

Share This Page