MES 30 - electrical problem

Discussion in 'Electric Smokers' started by beolson25, Feb 21, 2016.

  1. beolson25

    beolson25 Fire Starter


    I just bought a brand new smoker from craigslist.  Yeah ... not the best plan I guess but everything looked brand new with parts in the bags and all.

    Anyway ... I plugged it in the first time and the controller powered on so I thought I was good to go.  Well I set the temperature and time for 275 degrees and 3 hours.  Well ... there was never any heat.  The little red light came on on the controller saying it was heating but it never happened.

    Without going into details I went ahead and drilled the rivets and took off the back panel.  Everything looks fine.  So ... the next day I plugged it in again and it did actually heat up to 275 as set on the controller.  I had changed the outlet I was connected to so i assumed that was the problem.  Well ...On that day it heated to 275 and then stopped working.  I tried several different plugs in my house and now the element won't turn on at all again ...

    So ... in summary ... Controller turns on but the element never gets hot.  With strange intermittent periods of working(n o known reason)

    So ... I took out my handy dandy multimeter and started checking stuff but don't know enough to rule things out.  Below are some of the measurements and scenarios. 

    Please help me figure out my next steps.

    #1) Tested the Ohms across the heating element which was about 17 ohms.  That makes sense for an 800 watt element.  V=IR  --> 120/17=I=7 amps,   7 amps * 120 volts = 847 watts.  So it seems like the element is fine ... plus it is brand new.

    #2) Testing Power/Volts across the Heating element ... this one was a bit weird for me.  Testing over the two terminals produced a reading of zero volts.  Not too surprising ... When I measured between the heating element terminal on left side and the ground(Smoker frame) I get 120 volts.  Same with the terminal on the right side.  To me that seems strange ... A large voltage at the terminal but no flow ... Any thoughts? 

    #3)  Since the smoker stopped working after heating to 275 I thought maybe the thermal cut0off switch had tripped or was broken.  I tried 3 things to figure that out.

        a) Measured resistance across the cut-off and got .02 ohms ... so basically  it is fine ...

        b) Removed the two leads and measured the amps while the unit is turned on ... Obviously it was zero ... Had to check ...

        c) Connected the two leads ... effectively bypassing the cut-off switch.  No results ... still no heat.

    *** Another note.  The relay does click when turned on.  I know that is not a scientific measurement but I thought I'd share.

    So ... I have no idea what to test next ... I'm not sure it makes any sense ... Also I'm not able to get to all of the connections in the box on the bottom of the smoker which holds the relays etc ...

    I'd really appreciate any feedback ... I'm trying to avoid having to do a full re-wire because for the trouble I'll just go buy one from the store.  Safety is a concern.  Also, I'll be calling masterbuilt in the next few days to see if they will help even though I don't have a receipt.  :(
  2. miatawnt2b

    miatawnt2b Fire Starter

    Pull the terminals off the element and test voltage across. It sounds to me like the high temp cutout switch is flaky, but if you're getting 120V across the leads without the element in place I'd say your element is toast.

    If I remember correctly the high temp cutout button is wired in series with the heating element (which is kinda dumb IMO)
  3. miatawnt2b

    miatawnt2b Fire Starter

    Actually now that I'm thinking about your voltage test, I'm almost sure the problem is the high temp cutout sensor (button). They probably wired the cutout across the neutral. Instead of on the hot. As a test, cut both leads on the cutout button and twist them together bypassing the cutout. You can always re-attach with wire nuts.

  4. beolson25

    beolson25 Fire Starter

    First ... Thanks for the reply...

    So ... I already did what you mentioned. See item 3c listed below:


    #3)  Since the smoker stopped working after heating to 275 I thought maybe the thermal cutoff switch had tripped or was broken.  I tried 3 things to figure that out.

        a) Measured resistance across the cut-off and got .02 ohms ... so basically  it is fine ...

        b) Removed the two leads and measured the amps while the unit is turned on ... Obviously it was zero ... Had to check ...

        c) Connected the two leads ... effectively bypassing the cut-off switch.  No results ... still no heat.

    Any additional thoughts welcomed and appreciated... 


    I called Masterbuilt today and they are sending a replacement Heating Element.  I'm not convinced it will work but I'm glad they are "Playing Ball".  If it does not work I hope they can help me find the problem and get the parts or send me a new one ... Or worst case offer me a killer deal on a new one ... We shall see ... I'll update here once I get the element.

    Still looking for more feedback until then.
  5. beolson25

    beolson25 Fire Starter

    Small update ...

    I don't think I'll get a chance to test any of this until the weekend.  I'll provide the update as soon as I get a chance.
  6. beolson25

    beolson25 Fire Starter

    So ... I have still not had a chance to test the things people mentioned but I thought I'd ask a question ... 

    So .. the controller has 4 wires coming out of it.  Obviously one or more needs to be used for power.  1 or more needs to be used to read the current internal temperature, and one is needed to send the signal of "ON" to the relay/heating element.

    Does anyone have information on those 4 wires and what each of them is used for?

    I'm asking in case I need to wire in a new relay to see if I can bypass the board completely and use a properly selected relay that could turn on and off based on the low level power directly from the controller.  I may not need to do it but I thought I'd ask folks here.
  7. lamar

    lamar Smoking Fanatic SMF Premier Member

    Going by the schematic you posted, two wires supply voltage to the relay and the other two go to the temperature sensor. I have no idea about the colors they use.

  8. beolson25

    beolson25 Fire Starter

    I don't think I added a schematic ... There was one added recently but I think that schematic does not include the controller wires.  I'll have to go back and look.

    But ... here is my thought about that ... 

    only 4 wires ... if two are for temp sensor and 2 are for relay ... How is the controller unit getting power?
  9. lamar

    lamar Smoking Fanatic SMF Premier Member

    The 120 volts go to the control board that has a built in low voltage supply that supplies power for the micro chip which senses the temp of the probe and drives the transistor that then activates the relay. I would guess the relay voltage is 5VDC.

  10. beolson25

    beolson25 Fire Starter


    I think you were right.  That schematic does show the 4 wires.  

    2 comments on that ... 

    1) This is not a stock schematic.  It is actually a drawing a member made of his modifications to his MES.  I believe it is still probably pretty dang accurate to the stock version though.

    2) WTH ... Voltage regulator?  Transistor?  ... I'm not sure if it is possible to just take 2 of the wires and connect them to a Relay and have it turn on/off when the signal was high.  I'm assuming not ... :(
  11. lamar

    lamar Smoking Fanatic SMF Premier Member

    You assume right. It could be done but it would not be all that simple and you would not have any temp control.

    The positive DC voltage runs directly to the relay coil from the full wave bridge rectifier. The negative is switched to ground by the transistor .completing the circuit to the relay coil closing it. The temp sensor activates the microcontroller which in turn switches the transistor.

  12. travisty

    travisty Smoking Fanatic SMF Premier Member

    Wow, sounds like a bummer! You've already gone way above anything I would have done. My step one was going to be :

    Step 1: Call Masterbuilt

    The End!

    Lol, they are great over there and have taken great care of me when my smoker went out. I hope that having drilled the rivets out doesn't void the warranty or anything.
    beolson25 likes this.
  13. beolson25

    beolson25 Fire Starter

    Lamar ...

    beolson25 <-- Mind Blown!

    If I have to do a rewire I'll be talking to you ... :)
  14. lamar

    lamar Smoking Fanatic SMF Premier Member

    The thought that keeps coming back to me is do we know if that is the right schematic for your unit.

    BTW.......when you have time, slip by roll call and tell us a little about yourself and where you live.

    Last edited: Feb 24, 2016
  15. beolson25

    beolson25 Fire Starter

  16. beolson25

    beolson25 Fire Starter

    So ... I tested the Voltage with the Heating element removed.  Element Lead wire 1 to ground and lead wire 2 to ground.  Lead Wire #1 had the 120 volts and the lead wire 2 was basically zero.

    Also ... I plugged power directly to the element.  How long does it take to get Hot?  I waited several minutes and it certainly heated but didn't seem to get red hot which is what I was expecting with 120 directly to it.  How long should it take to get the element hot?
  17. beolson25

    beolson25 Fire Starter

    Ok ... Ran another test to see what would happen ...

    Previously I said:

    "I tested the Voltage with the Heating element removed.  Element Lead wire 1 to ground and lead wire 2 to ground.  Lead Wire #1 had the 120 volts and the lead wire 2 was basically zero."

    That was with the Controller powered on and the heat light on.... meaning it should be heating ....

    I got the exact same measurements when I turn the cotroller off.  Obviously I did not unplug the unit but I turned off the timer.  I still get the 120 Volts to the same Heating element lead.

    This make me believe that it is the Relay ... Ughhh ....

    So ... Masterbuilt has a heating element on the way.  I guess I'll call them today to see if this makes any sense.
  18. beolson25

    beolson25 Fire Starter

    Called Masterbuilt ... These people are great ... ... ... Sorta ...

    So ... the person I spoke to said that it sounds like a controller problem.  I actually disagree ... But they are going to send out the replacement controller free of charge.

    Sadly ... I explained that I thought it was the relay but I don't think that they replace that part ... I think they have to provide the whole smoker body.  ... :(

    I'm convinced that the issue is a bad relay. 

    Because I don't have a receipt she said they can send me a discounted smoker body for 65$ plus shipping or a whole new unit for 125$ plus shipping.  Sadly this puts my total out of pocket at over the cost for the original brand new smoker.

    Does anyone have a parts list for the parts I would need to make this work with a new relay?  I don't think I'll be able to install the new relay in the existing board due to the white insulation goo... 

    and if there are instructions for dummies that would be helpful too.
  19. miatawnt2b

    miatawnt2b Fire Starter

    OK, so you tested one heating element lead to ground and got 120V. You tested the other to ground and got 0. While that is correct it doesn't tell you if the circuit would work. The lead that reads 0 should have 0 resistance to neutral on the plug when the controller turns on the element. An easy way to test this is to remove the element, and test voltage between the two leads, not between one lead and ground. You aren't testing the whole circuit that way. When measuring between the leads, the voltage reading better be 0 when the controller is off and 120VAC when the controller is heating. Measure between the leads with the element removed.

    Also your thought about it being the relay may be correct, but you haven't proven it yet. I would expect that MB would have designed this thing so it switches (with the relay) the line voltage (or hot lead) and not the neutral. But maybe they didn't, or maybe the minimum wage robot putting the thing together swapped where the black and white wires for the main plug connect on the circuit board (and frankly this scares me enough to go check mine) If I find that my element is connected to line and it switches neutral with a relay, you better believe I'm ripping it apart and switching the wires on the plug.  Also, you may want to check your electrical outlet. A standard 120v grounded outlet has a small slot, a larger slot, and a round hole. A properly wired outlet will read as follows.

    With your meter, place one lead in the larger slot and the other into the round hole. It better read 0 volts. If it reads 120, then your outlet is miswired.

    I doubt the relay in the MB is 2 pole, and if it was, the fact you get constant 120 V on one side would likely mean the unit would heat all the time.

    My MES30 makes a pretty loud click when the heating element turns on and off. That click is the relay. Do you hear yours? 

    Last edited: Feb 25, 2016
  20. johnmeyer

    johnmeyer Smoking Fanatic

    A few thoughts from an old electrical engineer:

    1. AC measurements can be misleading because a voltmeter consumes almost no current and therefore can give you "phantom voltage" measurements. For instance, clip one lead to a cold water pipe and then stick the other in the air, and you will probably measure some voltage. That is just the voltage being induced into the test lead from nearby power lines. Then, with the lead still clipped to the pipe, touch the probe to the metal body of a power tool that is plugged into the wall. Even though the tool is probably "double-insulated," you will almost certainly get a reading -- possibly the full 120 VAC -- because the voltage is "induced" through the insulation to the metal body of the tool. There is no power behind that voltage and therefore no current and no danger, but the voltage reading will still be there.

    2. You can certainly replace the relay. You'll have to scrape away the conformal coating (the goo that is protecting the board and components from moisture) and then desolder the relay. You should be able to enter the numbers from the relay into Google and then find a reasonably similar item at Digikey. It has to be the same number of poles and throw (e.g., DPDT which is double-pole, double throw). This refers to how many switch are inside the relay, and how many contacts each switch controls. You also have to match the control voltage (AC or DC, and the number of volts). Finally, it has to be rated for the same (or higher) number of amps, because a relay designed for small amounts of current will have the contacts burn and fail pretty quickly if asked to switch an 800 watt load on and off. If it doesn't have exactly the same form factor, you may have to fasten it to something and then run wires from the relay leads into the holes on the circuit board. Form factor (i.e., having the relay contacts perfectly line up with the holes in the circuit board) is usually the toughest thing to match.

    However, if they are sending the entire controller, you should be able to just use that and not worry about the relay replacement.

Share This Page