• Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.

MES 40 remote

jdn54

Newbie
7
10
Joined Dec 13, 2016
I've read several threads describing flaws in the MES remotes, so I shouldn't be surprised, but here's one more. I've used my smoker 5 times now and everything has worked great (ribs, brisket, pork shoulder, meatballs, etc). I have a few chicken quarters on right now, temp set at 275, but the remote is telling me the internal smoker temp is only 18 degrees. Meat probe sitting in its sheath is reading around 235. I've had the smoker on for over an hour and it's clearly doing what it should, it's just odd that the smoker temp is reading at 18, especially since it's worked flawlessly prior to this. Any thoughts? I'm sure I'll be getting a Maverick soon, just wanted to see if there is an easy fix for the remote I'm not thinking of. I've tried turning on/off and recalibration get the remote.
 

newqreview

Fire Starter
73
22
Joined Sep 26, 2014
sorry, dont know.. Ive given up on tyhe remote and rely on the Mav.

Im considering getting the bluetooth...
 

Hot Threads

Top Bottom
  AdBlock Detected

We noticed that you're using an ad-blocker, which could block some critical website features. For the best possible site experience please take a moment to disable your AdBlocker.