SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Meat Thermometers › Problem with Taylor 1470
New Posts  All Forums:Forum Nav:

Problem with Taylor 1470

post #1 of 5
Thread Starter 
I used my Taylor 1470 for the first time Saturday and was generally pleased with the overall performance of the unit. However, when I washed the probe after the cook, the wire separated from the metal probe. I didn't use abnormal force in cleaning, it just came out. Has anyone experienced this? Will Taylor make it good you think? I emailed their customer service this AM.
post #2 of 5
I got a Taylor that I have had for at least 3 years & still using the original probe.
post #3 of 5
My Taylor 1470 is two years old and still working...however, there is a bit of a short in the on/off switch - but it still works most times.

I don't go the extra mile trying to take care of this unit, so I'll probably just replace the whole thing this summer.

I would think that Taylor would replace your probe at no charge, providing of course that you can prove you just bought it.
post #4 of 5
You can get replacement probes here. They also have good prices on the thermometers.
http://www.partshelf.com/tayod14digov.html
post #5 of 5
I've had better luck with Taylor when I call and talk to their customer service. I had some probes that went bad but it was after alot of use and they sold me replacements for $5.00 each.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Meat Thermometers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Meat Thermometers › Problem with Taylor 1470