or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MY MES 40 incher hates me....
New Posts  All Forums:Forum Nav:

MY MES 40 incher hates me....

post #1 of 4
Thread Starter 

So backstory, had 1 unit.. 2nd gen unit . Smoke exits on side, not top (too bad) anyway, 1st unit failed to properly report temps vs my own temp calcs. Masterbuilt replaced it under warranty. Second unit... worked good for the first few smokes, and now this is where i am at 4-5 months later. I was debating buying the new top exit smoker 40 inch because MB does have good customer service, but does anyone else experience these same heating issues as i do?  Or lack there of? Look at these pictures... The unit hasn't even heated yet, it's from just opening the door doing cleaning etc.. you can see all the temp area's have been cleaned, so it's no sludge or anything blocking the temps. You can see i have a igrill AND maverick reporting the same temp of 88... but MB 40incher says 102?? wtf, and it gets worse later on during the smokes... when i start opening and closing the cabinet, the temps get up to 30-50 degrees off..Try smoking at 225 when the unit's cap is 275 and it says it's 280.... and the mav/igrill say it's 210-215. I really like this smoker, but it seems to hate me.

 

post #2 of 4
Thread Starter 

Quick 20 minute update... The maverick is about 210.. for some crazy reason the igrill says 270...lol the MES meat probe is 218, the MES unit itself says 239. The #'s are all very random.  The maverick and probe seem to be climbing while the cabinet is staying about 239 for now.So in about 45 mins, we'll see where it all ends up, i just opened and added another igrill probe to the same rack as the other, quickly. So we'll see what's going on there...Sighs! frustrating, i should be able to focus on the meat!

post #3 of 4
Sounds like there is water in the maverick probe... It won't get above 210 if there is water in it.... Dry it out....
post #4 of 4
Thread Starter 
Quote:
Originally Posted by DaveOmak View Post

Sounds like there is water in the maverick probe... It won't get above 210 if there is water in it.... Dry it out....

Hi dave, the issue isn't the therms, they are accurate for the most part, obviously different parts of the cabinet will read differently..During my test smoke today, i've had no big issues with temps either way, seem within 20 degree which is fine, i am not smoking at 250-275 anyway. So being high by 20 isn't killing me..That being said, i am still battling the good ole florida humidity and the AMNPS... heh i wasn't getting the smoke quantity i wanted, so i just fixed that.. now to go double check that it didn't go out and the quantity is staying steady.  Unfortunately i cannot exactly load 6-8 butts out there right now to test how the cabinet will handle the load. So that'll be tossed in the fire on thursday MORNING.  Most my smokes go 24 hours for 8-9 pounders if i recall.

 

I may do a pie today to see how that is, hoping it'll be a big desert hit next week :)

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MY MES 40 incher hates me....