or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Meat Thermometers › Anyone Had Problems With The Meat Probe Side of the Maverick ET-733?
New Posts  All Forums:Forum Nav:

Anyone Had Problems With The Meat Probe Side of the Maverick ET-733?

post #1 of 3
Thread Starter 

I've used my ET-733 twice now. The first time I plugged in the probes I got a HHH code on the receiver display screen when I had it on its holder in the smoker. Since I was smoking ribs and didn't need the meat probe I removed it from the smoker and unplugged it. I'd only had it in there as a test anyway.

 

Yesterday, I smoked a brisket and again the receiver meat probe temp showed HHH or it was blank. I unplugged and plugged it in. I shut off both units, turned them on and re-synced them and suddenly, lo and behold, I was getting the meat temp and it remained working for the rest of the smoke until I turned the units off. Both units worked perfectly and it was great monitoring the smoke while sitting on the couch watching TV.

 

Anyone else had this happen? If so, did it just happen during the first use or has it been recurring?

post #2 of 3

I had this happen a couple of time when the probes were not pushed in all the way into the transmitter. Also found that I needed to power up the receiver first, then the transmitter.

 

Cheers.

post #3 of 3
Thread Starter 
Quote:
Originally Posted by knifebld View Post
 

I had this happen a couple of time when the probes were not pushed in all the way into the transmitter. Also found that I needed to power up the receiver first, then the transmitter.

 

Cheers.


Thanks. I re-read the instructions which said to power up the receiver first so that's what I did during the troubleshooting process. We'll see if the problem reoccurs or has been solved this next weekend. And I did notice that the meat probe was not pushed all the way in, as well. I'm hoping my experience will be the same as yours, that it'll be working fine from now on. Very glad I bought this instead of the 732.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Meat Thermometers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Meat Thermometers › Anyone Had Problems With The Meat Probe Side of the Maverick ET-733?