SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Retro Kit Install question
New Posts  All Forums:Forum Nav:

Retro Kit Install question

post #1 of 4
Thread Starter 

I just dry fitted my Wood Chip Retro Kit 2010 on my MES 30 (model 20010910). 

 

Is it proper for the lower flanges on new housing (the flanges that the new tray rides on) to make contact with the heating element?  The chip loader side of the housing is making solid contact with the element. 

post #2 of 4

I have the retro kit in my 40" and it is making contact to the heating element as well.No biggy.But,after using it a few times,the chip tray does become a little warped.Still useable,just makes sliding in and out a little squirley.

post #3 of 4
Thread Starter 

Ok, the video up on the MasterBuilt web site clearly shows what I'm seeing.  So this is a non-issue.  I did try to look last night before i posted, but the home box is Vista and it was being unhappy with the video.

post #4 of 4
Quote:
Originally Posted by LazyDavid View Post

Ok, the video up on the MasterBuilt web site clearly shows what I'm seeing.  So this is a non-issue.  I did try to look last night before i posted, but the home box is Vista and it was being unhappy with the video.


here is a link to the video

http://www.masterbuilt.com/video/sept2010/smokeretrokit.wmv 
 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Retro Kit Install question