New Posts  All Forums:Forum Nav:

MES water pan?

post #1 of 10
Thread Starter 

I have an MES electric smoker that is about 2 years old.  The water pan has started developing holes in it.  This started after about a year.  I'm patching the holes with epoxy but eventually I'll have to get a new water pan.  Anyone else have this happen?

 

Marc

post #2 of 10

Yep. I just wrap it in foil. Makes for easier clean up too. 

post #3 of 10

My water pan developed pin holes after my 3rd smoke. i was using a high acid stuff in the pan and just rinsing it out after. Just line it w/ heavy foiland smoke away.

post #4 of 10



 

Quote:
Originally Posted by eman View Post

My water pan developed pin holes after my 3rd smoke. i was using a high acid stuff in the pan and just rinsing it out after. Just line it w/ heavy foiland smoke away.


Using heavy foil as a liner is the answer, makes for fast clean up. Eman please explain about high acid stuff, were you talking about a cleaner?
 

post #5 of 10

I've had mine for more than four years, no problem.  I don't put anything other than water in it.  I usually spray it with PAM to make cleanup easier.  Spray the racks also.

post #6 of 10
Thread Starter 

I guess it really doesn't matter, the element bit the dust today.  It won't go above 90 degrees. I see a new smoker in my future!

post #7 of 10

My pan did the same thing & found a pan at Dollar General that fits better (or as good as) than the original. WWorld has some too. Got tired of messing with the foil.

post #8 of 10

citric acid oj , pineapple juice ,lime juice

post #9 of 10
Quote:
Originally Posted by Whisky View Post

I guess it really doesn't matter, the element bit the dust today.  It won't go above 90 degrees. I see a new smoker in my future!



Not that hard to fix problems w/ the mes don't chunk it unless you just want a new smoker.

post #10 of 10
Quote:
Originally Posted by Whisky View Post

I guess it really doesn't matter, the element bit the dust today.  It won't go above 90 degrees. I see a new smoker in my future!



What variant of the MES do you have?  Does it have an access panel in the back?  Is the back riveted on, or screwed on?

 

The most likely problem is that the connections to the heating element have crapped out.  It has happened to me twice.  Because my unit (4+ years old) does not have an access panel, it is a messy job to get to the connections.  My rear panel is screwed down, so that helped.  I've seen people here who talked about drilling out rivets and then replacing with screws. 

 

Look for articles here, many with pictures, that talk you through the repair.  Messy, but not too hard.  Hopefully the articles will show you how to make it better than before so that it does not happen again soon.  I've learned enough from them so that the next time will be a more permanent fix for me.

 

The basic problem is that the screws that allow you to remove the connection box are in the back of the smoker, through the plate that holds the heating element on.  They are hard to reach because of the chip box being in the way.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers