or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES 30" bass pro model. Doesn't smoke unless she is upto 275
New Posts  All Forums:Forum Nav:

MES 30" bass pro model. Doesn't smoke unless she is upto 275

post #1 of 13
Thread Starter 
I can't seem to get these chips smoking very good unless this thing is at max temp which isn't very good for a lot of the long smoking I want to do. I am using fine chips that have been soaked.

What am I doing wrong.
post #2 of 13
Quote:
Originally Posted by Winchested View Post

I can't seem to get these chips smoking very good unless this thing is at max temp which isn't very good for a lot of the long smoking I want to do. I am using fine chips that have been soaked.

What am I doing wrong.


IMHO, it's not worth trying to fix it.

The problem is the bottom of your chip drawer is too far from the heating element, or you don't have the drawer in right.

If your drawer has a big slab of extra metal on the bottom, make sure when you slide it in, that big piece of metal goes UNDER the heating element---Not between the drawer & the element.

 

If it's not the extra piece of metal, and you can't bend your drawer supports down closer to the heating element, the best thing is to get an AMNPS.  Actually that's the best thing to do, even if the chip burner is working normally.

 

Be Back.

 

Bear

post #3 of 13

Winchested,

Below is what I'm talking about above.

I don't know which MES you have, but this could be your problem:

 

 

It is possible that you don't have your chip drawer in properly.

If it looks like the one below, make sure the large part of the drawer slides under the Heating element, and the drawer goes above it, with the heating element sandwiched in between:

 

So.. The piece with the black scorch mark in the picture above goes under the heating element. 
 
 
Bear
 
post #4 of 13
Quote:
Originally Posted by Winchested View Post

I can't seem to get these chips smoking very good unless this thing is at max temp which isn't very good for a lot of the long smoking I want to do. I am using fine chips that have been soaked.

What am I doing wrong.

 

IMHO it is that you are soaking the wood chips, stop doing this and put them in dry and see if this makes a difference.

post #5 of 13
Thread Starter 


Here is the style of element and tray. Looks like 1/4 to 1/8 gap between tray and element.

Seems like chip tray is only like over 1/4 of the actual element.
post #6 of 13
Quote:
Originally Posted by Winchested View Post



Here is the style of element and tray. Looks like 1/4 to 1/8 gap between tray and element.

Seems like chip tray is only like over 1/4 of the actual element.

 

OK---If you can get it closer to the element, it would be a big help, but also like Cliff said--"Don't soak wood!!"

I know it says to soak them in your book, but the book lies!

 

However even if you get it working the way it should, it will still do the following:

No smoke until it gets going.

Then light smoke.

Then nice smoke.

Then too heavy smoke. (Not good)

Then nice smoke.

Then no smoke.

Then reload & start the above cycle again & again ever 20 minutes.

 

OR

 

Fill AMNPS with wood pellets.

Light one end properly.

Put AMNPS in Smoker.

Sit back & get perfect smoke for up to 11 hours without touching it.

 

Bear

post #7 of 13
Thread Starter 
post #8 of 13
Do not soak your chips, that's what's wrong I bet. Mine looks like yours and I never soak them unless I'm using my offset smoker.
post #9 of 13
Quote:
Originally Posted by Winchested View Post

Where's your chip tray? I'm not seeing it. I see the element but not the chip tray
post #10 of 13
Thread Starter 


Here it is.
post #11 of 13
Quote:
Originally Posted by Winchested View Post



Here it is.
Ok, gotcha. Just like the above comments recommend, don't soak. If you watch YouTube videos from John himself he says not to soak the chips I bet it'll work fine then.
post #12 of 13
Thread Starter 
Thanks fellas. Going to experiment with the loader position to see if it makes a difference.
post #13 of 13
Quote:
Originally Posted by Winchested View Post

Thanks fellas. Going to experiment with the loader position to see if it makes a difference.
Thank you for sharing, it's how we learn.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES 30" bass pro model. Doesn't smoke unless she is upto 275