or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES 30 = ZERO smoke. What am I doing wrong?
New Posts  All Forums:Forum Nav:

MES 30 = ZERO smoke. What am I doing wrong?

post #1 of 13
Thread Starter 
Hello. I have used this smoker a couple of times now and can't seem to get any smoke from my wood chips. They don't even burn, just toast up a bit. I've been doing trial runs (no meat) today trying things I've searched and found on these forums with no luck. I've opened and closed the top vent, pulled out the wood tray 1-1.5", pulled out the chip loader, all with no luck. I've been running at 250 now for a couple of hours and no burnt chips at all. I've attached some pics of the MES, chips inside, and chips I'm using. Any suggestions? I'm considering getting an amazn pellet tray, but I'd at least like to get this thing working as it should first. Thanks in advance.




post #2 of 13

Look under your chip drawer.

If there is a piece of metal between the bottom of the chip drawer and the top of the heating element, that is the problem.

 

There used to be a retrofix for that problem, but I wouldn't bother with seeing if they still have it. I would just get a 5" X 8" AMNPS, and you'll be smoking Happily Ever after.

 

 

Then you can go here & get going:

Just click on "Bear's Step by Steps".
 

 

Bear

post #3 of 13

No idea, but get a AMNPS.

 

 

Works great with the MES.

post #4 of 13
Thread Starter 
There is a piece of metal separating the chip tray from the heating element but it's attached to the tray and slides out with it. If this is the problem, can I just cut it off? I will be getting an AMNPS but would like to smoke a turkey tomorrow. Won't have it by then. Thanks again.
post #5 of 13
Quote:
Originally Posted by galpd320 View Post

There is a piece of metal separating the chip tray from the heating element but it's attached to the tray and slides out with it. If this is the problem, can I just cut it off? I will be getting an AMNPS but would like to smoke a turkey tomorrow. Won't have it by then. Thanks again.

 

If it slides out with it, that is the bottom of the drawer. That has to be there. The extra piece I'm talking about would be below the bottom of the chip drawer, but above the heating element. That would make a total of 2 pieces of metal between the chips & the heating element.

 

Unless you're talking about the piece that's longer than the chip drawer!!!----THAT piece goes under the element when you slide it in!!!!!  That's what your problem is---Make sure that part slides UNDER the HEATING ELEMENT !!

 

Bear

post #6 of 13
Thread Starter 

So.. The piece with the black scorch mark in the picture above goes under the heating element. I didn't thi it would fit that way but I'll try it. Makes sense. Thanks.
post #7 of 13
Quote:
Originally Posted by galpd320 View Post


So.. The piece with the black scorch mark in the picture above goes under the heating element. I didn't thi it would fit that way but I'll try it. Makes sense. Thanks.

 

Yup, That piece goes under the heating element. It keeps the heat from going down instead of up.

That piece would definitely keep your chips from burning at all.

 

Bear

post #8 of 13
Thread Starter 
Smokin like a chimney now! Thanks. I feel like a moron. grilling_smilie.gif
post #9 of 13

That's what this forum is for.  Nice work Bear

post #10 of 13
Quote:
Originally Posted by galpd320 View Post

Smokin like a chimney now! Thanks. I feel like a moron. grilling_smilie.gif

 

 

Just Doing My Job!!!

:super:

 

Now until you get your AMNPS, be careful you don't make your smoke to heavy. 

That can be worse than no smoke.

 

Bear

post #11 of 13

post #12 of 13

I love happy endings!

post #13 of 13

Dun dun dun........... Super Bear!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES 30 = ZERO smoke. What am I doing wrong?