or Connect
New Posts  All Forums:Forum Nav:

MES40 GFCI tripping

post #1 of 3
Thread Starter 

For the last year or so my MES will trip the GFCI when the heating element is powered. That first trip happen after the heat has been on for 2 or 3 minutes; then it will trip every time instantly. If I let it rest for a while, and then keep resetting the GFCI, I've been able to eventually get it to stay on for my smoke.

 

I notice that I have this problem only after it's been unused for a few weeks.

 

Last weekend I turned it on for the first time in 2 or 3 months, and it started tripping. I took out the heating element assembly, laid it on some bricks, connected both tan wires to the element, and powered it up outside the box with the yellow ground wire to the assembly disconnected; no trips after a 2 or 3 minutes. I then clipped in the yellow ground wire: trips again. I then connected the switched hot side tan wire and the ground wire; trips. So now I'm convinced that  the element  has some sort of leakage path to ground.

 

Then I do some googleing about heating elements. It turns out some heating elements have an insulator inside the rod that can absorb moisture from the air:

 

http://www.thermalsolutionsoftexas.com/repair-evaluation-heater.html

 

 

So last night I repeated the experiment with the ground wire disconnected, but this time I left the heater on for a good 15 minutes, until it was glowing red, to try to bakeout any moisture. When I reconnected the ground wire this time, no trips.

 

I think a bakeout could also work if you powered the MES from a non-GFCI outlet; personally I would be OK doing a 15-min closely monitored run for bakeout, but I would do unsupervised long smokes on a GFCI for better safety. In the meantime, I going to try to run my MES for 15 minutes every week or so.

 

I haven't heard of the higher-end smokers having this problem. There are heating elements that use non-moisture absorbing materials; perhaps that's what they use to avoid this issue.

 

 

post #2 of 3

If I were having that problem I would just contact MES and order a new heating element.  The tripping GFCI indicates excessive current on the ground line and that could mean a hot cabinet with current leakage in a bad spot in the element. That could leave you with a real "eye opening" experience when you touch that cabinet. 

 

I just replaced the element in my MES 40 and the element costs about $30 including shipping.  Well worth the money.  The moisture and salty environment in our smokers are tough on electrical heating elements. 

post #3 of 3
I had the same problem and contacted masterbuilt. The lady I had on the phone said right off the bat that it was a moisture issue and it sounded like they were familiar with it. Mine was new so I took it back to SAMs and got a replacement. Second one worked fine.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers