or Connect
SmokingMeatForums.com › Forums › Smoking Meat (and other things) › Sausage › Encapsulated Citric Acid question
New Posts  All Forums:Forum Nav:

Encapsulated Citric Acid question

post #1 of 15
Thread Starter 

I made some of my summer sausaage with the LHP (discussed in a prior thread) and some with ECA.  The sausage with ECA is mixed and stuffed but I can't start the smoking until tomorrow. Is it ok, with the ECA, to wait for hours in the fridge? 

post #2 of 15

Yes, it will be fine.

post #3 of 15
Quote:
Originally Posted by dwolson View Post

I made some of my summer sausaage with the LHP (discussed in a prior thread) and some with ECA.  The sausage with ECA is mixed and stuffed but I can't start the smoking until tomorrow. Is it ok, with the ECA, to wait for hours in the fridge? 



The capsulation surrounding the CA could melt (Could) and release the CA into the meat and make it mushy and turn white.

post #4 of 15
Thread Starter 
Would it melt in the fridge? 34f?
post #5 of 15

I do it all the time for summer sausage and have never experienced what Nepas mentioned. I am not saying it can't happen but I have never seen it personally. I have 80 lbs of summer sausage smoking right now with ECA in it that was mixed yesterday and left in the fridge overnight and then stuffed this afternoon. It is neither mushy nor white.

post #6 of 15
Quote:
Originally Posted by solaryellow View Post

I do it all the time for summer sausage and have never experienced what Nepas mentioned. I am not saying it can't happen but I have never seen it personally. I have 80 lbs of summer sausage smoking right now with ECA in it that was mixed yesterday and left in the fridge overnight and then stuffed this afternoon. It is neither mushy nor white.



I only had it happen 1 time.

 

I did however use powdered CA once and tossed it.

post #7 of 15
Quote:
Originally Posted by nepas View Post





I only had it happen 1 time.

 

I did however use powdered CA once and tossed it.



 

Interesting. What do you think melted it Rick?

post #8 of 15

I have used eca a few times with no troubles from an overnite stay in the fridge..

 

The eca didnt go thru the grinder did it??

 

  Craig

post #9 of 15
Quote:
Originally Posted by fpnmf View Post

I have used eca a few times with no troubles from an overnite stay in the fridge..

 

The eca didnt go thru the grinder did it??

 

  Craig



Nope

 

I never grind it, always by hand.

 

Joel i dont know why it did that.

post #10 of 15


>>>>>>>>>>>The eca didnt go thru the grinder did it??
 

Quote:
Originally Posted by nepas View Post

Nope

 

I never grind it, always by hand.



I was aiming that towards the OP Rick...I think it was you that explained why not to grind eca..

 

Craig

 

 

     

 

post #11 of 15
Quote:
Originally Posted by fpnmf View Post


>>>>>>>>>>>The eca didnt go thru the grinder did it??
 



I was aiming that towards the OP Rick...I think it was you that explained why not to grind eca..

 

Craig

 

 

     

 


Ahhh ok.....

 

post #12 of 15
Thread Starter 
Thanks for the help!
post #13 of 15
Thread Starter 
Quote:
Originally Posted by fpnmf View Post


>>>>>>>>>>>The eca didnt go thru the grinder did it??
 



I was aiming that towards the OP Rick...I think it was you that explained why not to grind eca..

 

Craig

 

 

     

 



HI Craig,

 

Nope on the grind.  Just mixed in before stuffing. 

 

Nepas,

 

I wonder if the cure process, or maybe the mix of spices broke down the encapsulation on the type of ECA you had in that one instance?!  Just a theory.

 

dave

 

post #14 of 15
Quote:
Originally Posted by dwolson View Post



HI Craig,

 

Nope on the grind.  Just mixed in before stuffing. 

 

Nepas,

 

I wonder if the cure process, or maybe the mix of spices broke down the encapsulation on the type of ECA you had in that one instance?!  Just a theory.

 

dave

 



Yeah was weird, only time that has happened. It was ECA from LEM. Have been using it still with this not happening again..  Maybe a bad batch of coating? who knows.

post #15 of 15
Quote:
Originally Posted by nepas View Post

Yeah was weird, only time that has happened. It was ECA from LEM. Have been using it still with this not happening again..  Maybe a bad batch of coating? who knows.


IMHO yer ECA from LEM was NFG. YMMV

 

  Craig
 

 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sausage
SmokingMeatForums.com › Forums › Smoking Meat (and other things) › Sausage › Encapsulated Citric Acid question