SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Meat Thermometers › Is my Maverick ET-73 busted or is it just the probes?
New Posts  All Forums:Forum Nav:

Is my Maverick ET-73 busted or is it just the probes?

post #1 of 10
Thread Starter 

I apologize if this topic was listed elsewhere, but I did search and really couldn't find the answer.

 

I smoked burgers and dogs on the weekend of the 4th,and during cleanup I noticed that the smoker probe wire on my ET-73 was pinched.  So the following day, I did the boiling water test on both probes as well as chefmate wireless with a pinched wire as well.

 

The test had the following results:

Food - 211 degrees

Smoker - 230 degrees

Chefmate - 210 degrees

 

I understand the thermometers being +/- 1 or 2 degress, but for a +18 degress is that a fault of the wire or the unit?

 

Thanks for the help

 

 

post #2 of 10

Swap the Smoker Lead and the Food Lead and post your results..

 

I be you have a bad probe

 

 

Todd

No Creosote! A-Maze-N Smokers

Reply
post #3 of 10

It's the probe wire. There is an easy mod for running your probe wires into the smoker so they don't get pinched. It's basically a threaded rod from a lamp kit that you can get at Home Depot. Just use the search & there are several threads on this mod. Or you can do like I did & just go to BBQ Guru & buy some eyelets. You will have to drill a hole in your smoker, but this will end your probe problem. Either way you will have to get a new probe, Maverick cust. service is very good & you may get a new one for free.

post #4 of 10
Thread Starter 

Thanks for the tip TJ.  Sometimes I forget the simple things when running test.  I ran the test and it came out perfect, so my probe is damaged.

 

I think I am going to order the 2 6ft food probe pack, and use one for the smoker temp.  The 3ft pobes it came with are way too short. 

 

Thanks for the tip Al,  I will consider this, so it doesn't happen again.  I am normally extremely careful with the probe leads, but that day I probably wasn't as careful and focused as I normally am since the in-laws were over and were testing my patience.

post #5 of 10

Just received my ET-732 about 1 week ago & I tried to use it this past weekend. This is what I wrote to Maverick:

Hello,
    I recently (withing the last 1 1/2 weeks) bought a new ET-732. I am really imnpressed with it features and some rteviews I have read. Yesterday, when I tried to use my unit I could never get it to "sync". I had both probes in the correct inputs. I bought new/fresh batteries (installed them). I turned on the receiver & then (about 3-4 secs later) turned on the transmitter. Unlike some reviews I had seen with video instructions that almose immediately both units started to display "room temp", mine had the --- display & then went to the HHH display. I never saw that satellite icon I am told I should see. This is new out of the box. I read in the Owners Instructions that came with my new unit that the HHH was a sign that the probe was bad. Well, both the meat & BBQ probes read HHH. I tried to make the unit work several times. In fact I left both units on with the HHH display for about 15 mins hoping that it would work. I was a little worried when I first opened the box the way the probes were packaged. I was worried beacuse of all that I had read about being careful not to pinch the wires (among other cautions mentioned). I could see flat spots in both probe wires.
  I really want to use this product. Is there a way I can get a new meat probe & a new BBQ temp probe? I really hope that Maverick can help me. Thank you for your time.
  I really like what I have read about the ET-732 and want to keep it & use it. So I guess I'll have to see what Maverick replies with. Again as I stated to Maverick, I was a little concerned about the probe wires when I opened the box. The flat spots in both probe wires.
post #6 of 10

There's a slim chance both probes are bad, but VERY Slim.

Pull out the probe at the connection, and push it back in.  Sometimes they do not seat all the way and read HHH

Try swapping the probes to see what happens

 

Let me know?

 

 

Todd

No Creosote! A-Maze-N Smokers

Reply
post #7 of 10



 

Quote:
Originally Posted by TJohnson View Post

There's a slim chance both probes are bad, but VERY Slim.

Pull out the probe at the connection, and push it back in.  Sometimes they do not seat all the way and read HHH

Try swapping the probes to see what happens

 

Let me know?

 

 

Todd

Todd,

  Thank you for the reply. I did that several times as well. To no avial.

 

 

post #8 of 10

Those probes have to be pushed in very tight.  They don't have the "feel" you normally get with a therm probe.

 

I wrap my wires in foil to give them a little mechanical protection.

 

Still, my Maverick meat probe went bad after about 6 smokes.  My 4 year old cheapo Acurite units are still chugging away.  It is possible Maverick has a problem with their probes.

 

Good luck and good smoking.

post #9 of 10

Maverick is good about the warranty on their probes.

I would call them and let them know your issue and what's going on.

The require you to send back the probes and/or unit and they'll send you out a replacement.

In-Turn, they send them back to their manufacturer.

 

UpinsmokeSJ, I sent you a PM

 

 

Todd

No Creosote! A-Maze-N Smokers

Reply
post #10 of 10

Todd,

  Thanks, again. I replied to your PM. It took a while because this site was so slow in loading pages. May have been "traffic", may have been a "firewall". I have contacted Maverick Customer Support (EMail). If I don't get a reply sometime today, I'll have to call. But both probe wires had a a few pinched areas in the probe wires (an initial concern because of all of what I have read about probe wires).

 

Quote:
Originally Posted by TJohnson View Post

Maverick is good about the warranty on their probes.

I would call them and let them know your issue and what's going on.

The require you to send back the probes and/or unit and they'll send you out a replacement.

In-Turn, they send them back to their manufacturer.

 

UpinsmokeSJ, I sent you a PM

 

 

Todd



 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Meat Thermometers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Meat Thermometers › Is my Maverick ET-73 busted or is it just the probes?