New Posts  All Forums:Forum Nav:

Meat Temp

post #1 of 17
Thread Starter 

Greetings all!  I'm having some issues and hoping to get some help from the community. 

 

I have a masterbuilt 30" (looks like a mini fridge) smoker.  

Currently trying to smoke a pork butt.  

 

I brined it in water, salt, and sugar (nothing fancy).

 

Used a dry rub which I got out of a book on smoking that I have.

 

I've been using apple wood with the pork, and its been on 225-250 degree range since 130pm EST.  Currently on hour 9.  Its not falling apart.  The internal temp of the meat is 135-140.  The pork butt did weigh in at 10lbs.

 

I do have to change out the woodchips frequently (about every hour to hour 15min) due to they become ash. 

 

I guess I have two questions:

 

1) Has anyone with the same electric smoker as I been having the same issue about getting meat to temp? 

 

2)  Should I leave the thermometer in the meat as it cooks?  Currently I've been taking it out while its in.  I just have a cheap metal spike thermometer with a gauge at the end.  And as a result maybe this is throwing off my numbers?  

 

Any help would be appreciated.  Thanks!  

post #2 of 17

Welcome..

This site has tons of info.

I would suggest you spend some time reading all the different forums and the WIKIs.

Then use the handy dandy search tool for specific interests!!

 

Have a great day!!!

 

Craig

post #3 of 17

That sure is a low internal temperature for your butt being in your Mes for that many hours. I would be a bit concerned about not reaching a internal temp. of 140 in 4 hours. How often are you opening the door on your smoker? Also have you checked your smoker chamber temperature with a good thermometer?  I don't open my smoker for the first 4 hours when smoking a butt. Only to probe the butt at the 4 hour mark.

I do own the same smoker as you and have had fantastic results with it.

post #4 of 17
Thread Starter 

I've been changing out the woodchips every hour b.c. they keep turning to ash which I read was bad.  And I assume this a problem.  

 

What kind of wood are you using?  Do your chips turn to ash within an hour at 225?  

 

Thanks for your reply!  

post #5 of 17

I don't empty my chip pan until i'm done smoking...are you using the chip loader on the side of the smoker? there is no reason to open the door to add chips when you load them with the chip loader.Apple is a good choice for pork...I use many different types of wood chips depending on the kind of meat i'm smoking.

post #6 of 17
Thread Starter 

Mine does NOT have a chip loader.  I have to open the door, pull out the bottom rack, and I have a water pan, and chip tray that has a lid.  I have to use gloves to get out the chip tray, carefully dump it and then top it off and put it back in.  I wish I had a chip loader thing on the side now!! I saw that on a youtube video once, however mine I think is a cheaper model :(   How often do you add chips via your chip loader?  

 

Apple has done well for me for turkey, and chicken wings.  I tried a pork tenderloin a while back and have had the same issue that I'm having now.  Still turned out okay, but I had to finish it in the oven..... not ideal.  

post #7 of 17

With my chip loader i add a very small amount of chips every 30 to 40 minutes. Every newer model comes with a chip loader. I really have to suggest a

A-MAZE-N smoke generator for your MES...you can get up to 10 hours of smoke without a refill of sawdust. They are a great product ...made in America... built and sold by a member here. They are very inexpensive for the quality product you receive. It would be a perfect fit for your MES with no chip loader. 

post #8 of 17
Thread Starter 

is this A-MAZE-N a replacement then for using the woodchips? 

 

I found my user manual online so you can see what I am dealing with.  The first part is assembly instructions but there are pictures.  http://www.masterbuilt.com/pdf/manuals/20070210%20ESQ3082%20Manual.pdf 

 

 

post #9 of 17

Yes it is...you load with dust...light it and set it on the bottom of you smoker for up to 10 hours of thin blue smoke. On the top of each page is search bar...type in amazen and you will get many results on this great product. 

For some reason you link isn't working for me.. :(

post #10 of 17
Thread Starter 

I'll have to look into that.  Sounds like it would be a solution to my issue.  

 

Go to this link http://www.masterbuilt.com/manuals.aspx  you'll see in a blue outline one that says , "Electric Smokehouse (Bruce Foods), then go 3 down on the list to "Electric Smokehouse" It has 3 model numbers next to it.... 

 

Can I just put that dust stuff in the pan and let the heating element of the smoker get it going?  

 

Thanks again for your help!  

post #11 of 17

That is a big piece of meat.  Be sure your smoker temps are correct at the grate.  If so, sit in for a long wait, cause you are about to hit the dreaded stall.  Be patient and you will be rewarded.

 

Good luck and good smoking!

post #12 of 17
Thread Starter 

Well after 10 hours of smoking, and 3-4 hours of it being at 140 degrees I ended up putting it on the grill and finishing it.  It tasted great.  However, I feel that the issue I'm having with temperature is the fact that I have to open up my smoker ever hour and the meat can't get going.  I'm going to look into that dust stuff b.c. I think that will be a good fix.  One of these days I'lll upgrade my smoker! 

 

Oh and Venture, Welcome to the Big Ten!  I look forward to the Ohio State v Nebraska game this season!  And yes I'm a buckeye!  

post #13 of 17

Well it sounds like it ended well, with a good meal even with all your troubles.

post #14 of 17
Quote:
Originally Posted by John Brennan View Post

Well after 10 hours of smoking, and 3-4 hours of it being at 140 degrees I ended up putting it on the grill and finishing it.  It tasted great.  However, I feel that the issue I'm having with temperature is the fact that I have to open up my smoker ever hour and the meat can't get going.  I'm going to look into that dust stuff b.c. I think that will be a good fix.  One of these days I'lll upgrade my smoker! 

 

Oh and Venture, Welcome to the Big Ten!  I look forward to the Ohio State v Nebraska game this season!  And yes I'm a buckeye!  


Opening your smoker surely doesn't help, but you must have some bad thermometers there too, because if it took 10 hours to get to 140˚, and you ate it & didn't get sick, you are very lucky.

The rule for safety (if you're probing your meat at the start) is "You should get the meat from 40˚ to 140˚ in no longer than 4 hours to be safe to eat".

 

I would check your thermometers, read a lot of posts on this forum, and try to cut down on your door openings.

 

Bear

 

post #15 of 17

I suspect the thermometer as well and opening the smoker to much.

post #16 of 17
Thread Starter 

I'll look into getting a new thermometer for sure.  I'm going to experiment with running the smoker for a couple hours with some water and woodchips in the woodchip tray and see if that helps keep the woodchips longer while still giving the flavor.  I'll try this with something in-expensive, or might just run it on empty with no food, and see how they last.  Anyone have any thoughts on this? 

 

When I pulled the meat at 140 it went to the grill and raised a LOT faster in temp than it did in the smoker.  It was around the 160 range when pulled. 

 

My main issue that I've discovered is that the woodchips turn to ash so quickly and the only way to change them is by opening the door.  No fancy little side loader :(  

post #17 of 17

Use chunks instead of chips. They should just smolder not burn right up. Is your smoke thin and blue or thick and white? Like they said above. "Get a good thermometer."

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Pork