or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Wood Smokers › lang 60 user trouble
New Posts  All Forums:Forum Nav:

lang 60 user trouble

post #1 of 5
Thread Starter 
Have new lang 60 cant get left side to 300 degs.i have two mavericks i jyst tested in boiling water.in chamber probe each side probe in middle. Start chimmeny kingsford and 6 splits of oak,tried pecan even went lowes bought smoking wood all hickiry from lowes.i can get temp to 300 on left side when chamber door is at open latch soon close it down temps plummet. Stack open intakes open. Im at loss here very frustrated.
Edited by sacedbysapp - 1/18/16 at 5:28pm
post #2 of 5
Thread Starter 
I have it level and nose up. Can someone go thru steps how they heat up there langs.shpuld i leave chamber door at open latch to get to 300 deg thwn clse it down? Ive followed the steps on lang site just not working for me.
post #3 of 5
I live right down the road from Lang. Like 15 miles. I stop there from time to time. If it was me I would stop by. For you I would call. These people are top notch and are always willf to help.
post #4 of 5
Thread Starter 
I did said use bigger splits build bigger fire.
post #5 of 5
Quote:
Originally Posted by sacedbysapp View Post

I did said use bigger splits build bigger fire.

I live in Blackshear and in front of the IGA they have the big guns out. They are about 8' long.

They always load up the box. I have watched. They control the heat though. And the end product would make anyone proud.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Wood Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Wood Smokers › lang 60 user trouble