or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Help with new 40" mes. Model 20072619
New Posts  All Forums:Forum Nav:

Help with new 40" mes. Model 20072619

post #1 of 3
Thread Starter 
I had the old version of the 40" mes for years and it finally bit the dust. Wiring burned up. I attempted to fix but the metal box in the back was toasted so bad it wouldn't hold the element up. I didn't feel comfortable rigging something that I leave running unattended. So I had decided to wait a while to buy a new one. Last Saturday we pulled the last pack of smoked ribs out of the freezer. As soon as we started eating them my wife said we have to replace the smoker now. So I went to SAMs and bought the new 40 model 20072619 I think it is.

Here's the problem. I unboxed it this morning and put it all together and started the break in process. It fired right up and ran for about 30 minutes and was up to 185 degrees. I came back ten minutes later and the screen was blank. The outlet I was using is out under my covered shop/carport and it has a ground fault receptacle at the head end of that circuit which had tripped. The breaker didn't trip, only the ground fault receptacle. So I reset it and tried again. It fired right up and started heating. Came back 20 minutes later and it was out again. This time I moved it into my garage which is fed from a different circuit and out of a completely different panel. It also has a ground fault receptacle and within 20 minutes that one had tripped. No breaker trip again, just the ground fault receptacle. I know it's not load and I think by trying two different circuits that I have ruled out house wiring as the culprit. Anybody have any ideas why it would be tripping the ground fault receptacle? Neither one of these ever false trip. Wiring on both circuits is 12-2 fed from a 20 amp breaker. No extension cord was used. What gives?
post #2 of 3

You probably should call MES and see why the draw is so high or spiking or whatever. Any of the wire connections loose?

post #3 of 3
Thread Starter 
I called masterbuilt Tuesday. They offered to send another element but I wasn't crazy about rebuilding a brand new smoker so I exchanged it at SAMs for a new one. Unpacking and testing it tonight so hopefully it will work correctly.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Help with new 40" mes. Model 20072619