SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Char-broil vertical electric - second smoke run and still no smoke from the chips...Help???
New Posts  All Forums:Forum Nav:

Char-broil vertical electric - second smoke run and still no smoke from the chips...Help???

post #1 of 10
Thread Starter 

I'm on my second attempt at smoking with a Char Broil vertical electric smoker -

 

For those not familiar, this is an electric water smoker with a flat "heat plate" about  1" below a ring electric burner. The water bowl is about 4" deep and is just barely above the electric burner. Obviously, food just above that water bowl - top grate is about 4" above water bowl.

 

 

Last time,  I soaked hickory chips for about an hour, spread a good sized layer of them all around on that heat plate, but not touching the electric burner just so they wouldn't flat burn and raise the temp way way up.

 

I didn't open the vent at all (just to see), and it didn't do anything but bake for a long time, and then about 3 hours in, a whole lot of smoke came up and the temp shot way way up, and the food temp went through the roof. So I kinda figured I'd oversoaked the chips and had no circulation, so the chips didn't get enough oxygen to actually smolder and produce smoke, until the water boiled down and then things got going in a hurry.

 

 

On this second run today,  I soaked the hickory chips for only 1/2 hour, and opened the vent 1/2 in (50% of opening), and it smoked a little bit for about the first 30 minutes, then smoke stopped coming out altogether.

It's now been running at 180-190 (with the temp thermostat on HI ), with no smoke at all.

 

I can see uncharred chips sitting around inside very close to the burner, but just not generating any smoke.

Good air coming out of the vent, so I know I'm getting circulation inside..

 

Temps are running in the 190 range, (turkey breast now at about 140)

 

But I'm essentially only baking the turkey, not smoking it at all -- without hickory chip smoke hitting them, they're just baking.

 

Why am I still not getting any smoke/smolder coming from the chips??

 

This is the same exact effect I get using one of those little chip-boxes on  my grill -- the chips simply never do anything at all in the way of smoke.

 

Is soaking the wood chips really just some sort of bad idea that no one ever really does with any smoke success?

 

 

 

post #2 of 10

welcome1.gif    Glad to have you with us!

 

 

I'm not familiar with your smoker, but I'm sure there are some here who are. Most of us don't soak chips. Did the manufacturer say to soak them? If the chips are below the heating element as you say it would seem like they should be dry. If the smoker has a top vent it should be open all the way. I'm sure someone with better answers will be along shortly. Good luck.

post #3 of 10

I have the same element in a 30 gallon drum and I took a small bowl and drilled holes all over and fill with soaked chunks/ chips. I soak them so they dont burn up right away, but they take a while before they start to smoke. 

 

woodtray.jpg

post #4 of 10
Thread Starter 

OK, so here is a shot of the smoker beforehand - just so you know the type.IMG_3167.JPG

post #5 of 10
Thread Starter 

And here's the result -

IMG_3170.JPG

post #6 of 10
Thread Starter 

That may be what I'll have to do -- move the water bowl one level higher, and put the chips in a pan directly above the element like that.

Or not soak them.

 

Is that pan sitting directly on the element? Seems like that'd be a shock hazard, though maybe the resistance is enough that you don't get voltage carried onto the plate.

You could always just not touch that plate - although I'd think it might short the element and keep it from heating all the way..

 

 

For this run, I had to get medieval and put a pan of burning wood chunks UNDER the smoker after about 2.5 hours..

_that_ got some smoke going up through the thing!!

 

 

I'll try this post with no pic and see if it still needs moderation -- starting the thread didn't...

post #7 of 10
Thread Starter 

I've posted a few other comments with pictures, but those came up needing moderation, so some mod will have to allow them.

I guess it's because I attached pictures -- although the site also seems to think I'm offline, and I'm certainly not!  :D

post #8 of 10

It's sitting on the little round pan that came with the element and both are sitting direct on the element. It's the same element you have 1500 watt.

post #9 of 10

I added lava rocks around the element to hold temps and to protect the element.Put chunks on rocks and shop vac ash when it cools down.

post #10 of 10
Quote:
Originally Posted by michael ark View Post

I added lava rocks around the element to hold temps and to protect the element.Put chunks on rocks and shop vac ash when it cools down.



I have lava rocks under my element also, I guess It helps in the winter. 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Char-broil vertical electric - second smoke run and still no smoke from the chips...Help???