SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES 30" first time use - chips went up in flames!!!!!
New Posts  All Forums:Forum Nav:

MES 30" first time use - chips went up in flames!!!!!

post #1 of 17
Thread Starter 

Okay, I preheated my MES with the chips already in the tray. When I opened the door to put the meat in, the chip tray was engulfed in huge billowing flames!! I immediately took the tray out until it stopped flaming and then put it back in. I was certainly not expecting the flames..what, if anything did I do wrong? Is this normal? Thanks so much

post #2 of 17

Get an AMNS. Most of the guys with MES get them, other than that you can try soaking the chips or get the retro kit from Masterbuilt.

post #3 of 17
Thread Starter 

I am looking into that soon Al....but today is just the first use with the tray provided. I don't know how long it was flaming inside. Have I ruined my new smoker??

post #4 of 17
Quote:
Originally Posted by darkmoondreamer View Post

Okay, I preheated my MES with the chips already in the tray. When I opened the door to put the meat in, the chip tray was engulfed in huge billowing flames!! I immediately took the tray out until it stopped flaming and then put it back in. I was certainly not expecting the flames..what, if anything did I do wrong? Is this normal? Thanks so much


Check and see if the heating element is tight against the bottom of the chip drawer.

It should not be tight against, or touching.

If it is, see if you can manipulate any of the metal down there to get it to not be against.

However---DO NOT bend the heating element---It could break!

 

Let us know how you made out.

 

An AMNS would solve your problem, but you should still have a functioning MES chip burner.

 

 

Bear

 

post #5 of 17
Thread Starter 

Bear I just went outside and checked. The chip drawer is very close to the elements but not touching them. All chips are now smouldering ash.  Thanks, Karen

post #6 of 17
Thread Starter 

Gosh I still can't understand how/why this happened.....stupid girl smoker, lol!

post #7 of 17
Quote:
Originally Posted by darkmoondreamer View Post

Bear I just went outside and checked. The chip drawer is very close to the elements but not touching them. All chips are now smouldering ash.  Thanks, Karen


Hmmm,

I wish I knew which drawer you have.

Is it the "half" drawer (half as big as the plate under it)?

If it is, that one usually has the problem of not burning good enough---not burning too good.

Most of us never soak out chips---If it's gonna flame up, it will just flame up 2 minutes later, if you soak them. Been there--Done that!

If it keeps flaming chips up, I would try to get the element farther away from the bottom of the drawer.

 

You could also try an experiment that works for Fife:

Put a few chips in the chip dumper, and slide it in place, but don't dump them into the drawer.

See if they will smoke in the dumper. If they do, try using it like that. Then after they burn out, turn it to dump the ashes into the drawer. Then you can put more in the dumper & repeat.

 

I know that's not the way it's supposed to work, but if it is entirely too hot in your drawer, it might work for you, like it does for Fife.

 

Keep us posted.

 

Bear

 

post #8 of 17
Quote:
Originally Posted by darkmoondreamer View Post

Gosh I still can't understand how/why this happened.....stupid girl smoker, lol!


Smokers don't care what sex we are---They get hot no matter who is with them.

 

They probably are female, because they can often get ornery.  (No offense to any of the lovelies on this forum!)

 

 

Bear

 

post #9 of 17
Thread Starter 

This is a picture of the model I have..The chip drawer is large....only 5 1/2 inches of rack to the left side of the drawerPhoto0153.jpg

post #10 of 17

Karen,

Funny you should post this problem today. While changing the dust in my AMNS I threw a small handful of chips in my chip tray  and when I opened the door to put the AMNS back in my chip tray was also on fire. This is the second time I have had a fire in the chip tray since I installed the chip tray mod. I tried to adjust the tray a little further from the element as suggested by Bearcarver, probably need to adjust further. I have also soaked chips with in water and that seemed to help. Good luck

post #11 of 17

It looks like that is then new kit. Try to use chunk it should work well and give ya lots of smoke.


 

post #12 of 17

One other thing I do is I dont flip the chips I let them stay in the tray. YES it does work. I to have the MES40 and mine works well with some mods.

post #13 of 17
Quote:
Originally Posted by darkmoondreamer View Post

This is a picture of the model I have..The chip drawer is large....only 5 1/2 inches of rack to the left side of the drawerPhoto0153.jpg


OK--That is the one with the full drawer.

If you got that new like that, then they are now putting the full drawer in at the factory, so people don't have to get a retro kit to swap out the half drawer for the full drawer.

I'm glad to see that!

 

All I can say is, if I were you, I'd experiment with all of the suggestions above, and figure what works best for you.

 

Meanwhile, I would get a 6 X 8 AMNS from Todd, and some different flavors of miracle dust. You're gonna want to get one anyway, even if you get your MES figured out.

 

An AMNS takes all of the headaches out of smoking!

 

Keep us posted---We will continue to try to help.

 

Bear

 

 

post #14 of 17
Thread Starter 

Thanks again everyone! Bear I have already talked to Todd. May 1st they are coming out with a new design that will hold dust AND pellets!

post #15 of 17
Quote:
Originally Posted by darkmoondreamer View Post

Thanks again everyone! Bear I have already talked to Todd. May 1st they are coming out with a new design that will hold dust AND pellets!


OK---I didn't know when that was happening.

 

post #16 of 17

I did the same thing....  You should not heat up the unit with the chips in the drawer.  Wait until it is up to temp and then add the chips. 

 

 

Good luck....

post #17 of 17
Quote:
Originally Posted by Birdman1099 View Post

I did the same thing....  You should not heat up the unit with the chips in the drawer.  Wait until it is up to temp and then add the chips. 

 

 

Good luck....


If one is having flare-up problems, That Is A Very Good Tip !!!!

 

Bear

 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES 30" first time use - chips went up in flames!!!!!