RediCheck "Smoker" thermometer trouble

Discussion in 'Meat Thermometers' started by bilvo47, Dec 1, 2007.

  1. bilvo47

    bilvo47 Fire Starter

    I have the RediCheck "Smoker" thermometer and am using it for the first time today. The moniter connected directly to the probes is working fine but the remote is just flashing " - - - " where the chamber and meat temperature is supposed to read. Any suggestions?
     
  2. walking dude

    walking dude Smoking Guru SMF Premier Member

    rip mentioned summin bout having to reset the remote part of it.......summin bout pressing both buttons to gether at once........

    can't really remember..........
     
  3. richtee

    richtee Smoking Guru OTBS Member

    Check remote batts, check programming instructions,check range from remote, all else fails, try a scientifically applied force vector <smack the silly thing>
     
  4. rip

    rip Smoking Fanatic

    Mine has a reset button on the reciever and the thurmo...........push them. NOW![​IMG]
     
  5. bilvo47

    bilvo47 Fire Starter

    just figured it out - there's a "tx" button inside the battery compartment - when I pushed it the thing started working - crazy - thank y'all for the help.
     
  6. rip

    rip Smoking Fanatic

    Glad you got it goin, I was goin to take mine back........then I saw the reset buttons.[​IMG]
     
  7. bigarm's smokin

    bigarm's smokin Master of the Pit OTBS Member

    frustrating little buggers aren't they? [​IMG] I have one with a transmitter and remote unit, they both need to be reprogramed EVERY time I use it, soo..... I never use it. [​IMG] Like Terry says, (the other Terry), "relax, don't worry, have a home brew" [​IMG]
     

Share This Page