MES Internal temp sensor

Discussion in 'Electric Smokers' started by fourthwind, May 17, 2010.

  1. fourthwind

    fourthwind Master of the Pit OTBS Member SMF Premier Member

    OK so as most of you know I use my MES a LOT. I noticed on a pastrami smoke yesterday that the gill level temp was 25° higher on the 2nd from the bottom grill than what the MES was set for. In the past it was always within a few degree's of my digital probes. This morning I decided to check things out since I have a smoke on a large t-bone roast today. After pluggin it in, and turning it on, I saw that the MES thought it was at 32°. Ambient air temp was 65°, so I rigged up two digital probes. One at the vent and one at the grill level (sencond from the bottom is where I typically cook) I started with setting the MES temp to 110° and whithin 15 minutes both my digitals said the temp inside was about 200° and the MES said it was at 80°. At this point i am panicking since I wanted to do a cooler smoke today. Well after another 15 minutes the temps on the probes remained at about 205 and the MES said it was at 110. I set the temp one the MES to 150, and let it go another 15 minutes. Now the MES said 150 and probes 225. Long story short I kept playing with this and it looked like the MES probe takes longer to catch up. After an hour and a half I have a 30 degree split between MES and probes. Usable but annoying.

    Anyone else see this kind of lagging?

    Is this a pre cursor to a total failure? [​IMG]
     
  2. ronp

    ronp Smoking Guru OTBS Member SMF Premier Member

    Have you tried to reset it by unplugging it?
     
  3. fourthwind

    fourthwind Master of the Pit OTBS Member SMF Premier Member

    I unplug every time I finish smoking. Cycled it several times this morning as well. I also remove the controller and store it in house when it's not in use. I checked the contacts of the controller as well. no corrosion or wear.
     
  4. ronp

    ronp Smoking Guru OTBS Member SMF Premier Member

  5. fourthwind

    fourthwind Master of the Pit OTBS Member SMF Premier Member

    Just got off the phone with Masterbuilt. Talked to a very polite lady in customer service that eventhough my unit is well out of warranty (like a year out) is sending me a new controller. Should be here in a week. I cannot stress enough how impressed I am with that kind of service and product support. I use this thing a lot. Typically at least two smokes a week throughout the year. More in the winter than summer, but man call me impressed.

    [​IMG][​IMG][​IMG][​IMG][​IMG] thumbs up for Masterbuilt service.

    One of these day's I'll have to upgrade to the 40 inch when I can afford it.
     
  6. ronp

    ronp Smoking Guru OTBS Member SMF Premier Member

    Very cool.[​IMG][​IMG]
     
  7. Do you clean your smoker after use? If not, try cleaning the built-in probes on the back wall (my 1,200 watt 40" has two). They may be covered with crud not allowing an accurate temperature reading.

    Just a thought.

    Phillip.
     

Share This Page