Mavrick Customer Service.

Discussion in 'Meat Thermometers' started by rickw, Feb 10, 2009.

  1. rickw

    rickw Master of the Pit OTBS Member

    I've had my ET-73 since 11-09-08 and today while running the usd noticed what I thought was a low temp reading compared to the flush mounted therm. The outside therm usually runs 40 degree less than the middle of the grate. Well I checked it against another therm plus did a boil test and sure enough it was 10 degrees off.

    I called Maverick and they are sending me a new probe for the smoker. I'm pretty pleased with their CC.
     
  2. pignit

    pignit Master of the Pit OTBS Member SMF Premier Member

    I got an ET-73 for Christmas. The latch on the transmitter battery cover was broke from the start. I called CS and the guy said, no prob, send one right out. About a week later I get a new probe in the mail. I called again and I got a very nice lady in CS. We had a good laugh... she got me address... told me to keep the probe and a few days later I received two new covers for the transmitter. I'm happy!


    [​IMG]
     
  3. richoso1

    richoso1 Smoking Guru OTBS Member SMF Premier Member

    Glad it worked out for you. Good customer service speaks louder than paid commercials.
     
  4. rickw

    rickw Master of the Pit OTBS Member

    Got the new probe today, now that's service.
     
  5. shorts

    shorts Meat Mopper

    Rickw what's the number. I've got three dead probes and one broken power switch on a remote...
     
  6. rickw

    rickw Master of the Pit OTBS Member

    PM sent....
     
  7. shorts

    shorts Meat Mopper

    Thanks...got it!
     

Share This Page