• Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.

Masterbuilt 1050 Second Day (sad)

pebcakpro

Newbie
17
18
Joined Jul 30, 2021
Decided to do some hotdogs on the second day. I put them on 225 and got a nice color on them. I turn the temp up to 350 to crunch up some buns and get some lines on the dogs. 10 seconds in and the fan stopped working. I really don't want to return it. So, I reached out to Masterbuilt and got these tips. I'm going to work it through and see how it goes. I hope this helps others if they run into the same problem. I'll let ya know what I find out.

Thank you for contacting Mastebuilt customer support. To better assist, please follow these troubleshooting instructions. The instructions are below:

1) Please disconnect the fan from the wiring harness, plug the fan into the controller, and then turn on the controller and set the temperature. (If the controller shuts off/resets the fan isn't good)

2) Unplug the fan and plug the wiring harness into the controller and then set the temperature. (if the controller resets/turns off wiring is bad)

3) Unplug the wiring kit and the fan, turn on the controller, and set the temperature. (if the controller resets again then the controller)
 

smokerjim

Smoking Guru
OTBS Member
SMF Premier Member
5,568
2,596
Joined Jan 14, 2014
looks good, hopefully ya found your problem
 

Latest posts

Hot Threads

Top Bottom
  AdBlock Detected

We noticed that you're using an ad-blocker, which could block some critical website features. For the best possible site experience please take a moment to disable your AdBlocker.