• Some of the links on this forum allow SMF, at no cost to you, to earn a small commission when you click through and make a purchase. Let me know if you have any questions about this.

ERR 2 with my MES 40

hlsrtony

Newbie
2
10
Joined Oct 28, 2016
My MES 40 is throwing an ERR2 as soon as I turn it on and select "Set Temperature".. it beeps, error goes away and I continue to enter temp and time. Heat light then comes on but it does not heat.

Looking for any ideas prior to getting a new one (definitely not a Masterbuilt though).

Thank

Tony
 

inf3st

Newbie
13
10
Joined Nov 1, 2016
I would call masterbuilt. They are pretty good about helping even if the warranty is up. You never know.
 

andypanda

Newbie
17
12
Joined Sep 10, 2010
Wow. This exact thing happened to me yesterday with my MES40. The ERR2 started a couple of smokes ago on mine. I thought it was just the meat probe was spent. Then yesterday I turned the smoker on, hit set temp, got ERR2 like I had before. I set the temp to 275* and it heated up to @ 130* and then temp decreased back down to air temp. I saw the 'heating' light was on but the burner was cool...

I hope to break it down this weekend and see if it can be repaired. I hear that Masterbuilt wont sell the burner as a part now. Least that's what I read online...I also saw on you-tube the wires to the burner have a tendency to break down and lose contact...Hopefully its a simple fix.

Ill let you know what I see when I get some time to look it over...Bad timing for this for me....
 

cmayna

Master of the Pit
OTBS Member
★ Lifetime Premier ★
3,548
1,225
Joined Jun 23, 2012
If you google  "masterbuilt err2"  you will find a couple links to discussions.  With what I'm reading, it might be simply a loose or contaminated connection between the wires crimped to the heating element.  Then again, it might be something way more involved like with the controller.  I personally would look at the wire connection to element just to eliminate that possibility.

Maybe someone with hands on experience to this issue will chime in.
 

andypanda

Newbie
17
12
Joined Sep 10, 2010
Ok, Got a few mins to take a look, and sure enough it was one of the connectors to the heating element had basically disintegrated.

Looking at the back panel of your smoker it is the small cover at the bottom. 6 screws and a thin rubber gasket that peeled off. There are 2 well insulated wire connections. Both look a little charred and compromised. One of mine was disintegrated where it was just touching the heating element connection. I touched it and pieces just crumbled away. I picked the rest of the rust and chunks off the wire and used a small wire brush to clean off the paddle to the heating element.

Gotta run to the h-ware store for a new paddle connector to crimp to the wire. I also plan to get some shrink-tube to slip over the connection and an inch or so up the wire for good air and moisture free connection.

I thought about tearing apart the other connection and rebuilding it but I think I will wait..I dunno...don't wanna push my luck...

Happy to hear any other electrical recommendations for redoing this connection. Will the shrink wrap be enough insulation?

Ill post back after I get the parts and finish the fix...
 

dr k

Master of the Pit
OTBS Member
2,806
667
Joined Mar 22, 2013

Strip rubber off of back plate and stretch over screw heads so I can rip it off and reinstall quickly to inspect when unplugged before my next smoke so no future dilemmas.  Once bitten twice shy so to speak.  I make these and mail them to SMF members with this exact problem.  You can wire nut the pigtail setup in the pic above or solder and shrink tube like I did to the MB leads.  PM me if you want a couple. No problem I like doing this kinda thing.

-Kurt
 

hlsrtony

Newbie
Thread starter
2
10
Joined Oct 28, 2016
Thanks for all the replies, AndyPanda when I looked mine was exactly as you described. Cleaned the paddle, crimped a new connector on and all is working. It still throws a Err2 upon power on but otherwise heats up, shuts on off at temperature and I am good to go. 10 minutes fix with a $0.10 part.

Annoys me that I did not just dive in as I am a tinkerer but have had so much trouble with this smoker and I was entertaining that day and all my food plans were in the smoker that day.

I may have one more crimp and clean in the unit before the heating element falls apart.

Thanks again
 

bird731713

Newbie
2
10
Joined Nov 6, 2016
jumping around trying to get some one to help. Ordered a new control board for my older Gen 2. Now the older ones have 3 plugs a 5 wire a 3 wire and a two wire. my new control board has a 5 wire and two 2 wire plugs which I'm told all the newer ones have.

 The part supplier says they distribute the parts for MB and they told them to print on the invoice to call tech support to learn how to hook the new 2 wire to the old 3 wire.

 I did and the tech had no idea what I was talking about. He told me I would have to buy a new smoker because the parts for the old GEN 2 are no longer available.

 But apparently there is a fix. has anyone had this problem and could tell me how to connect the wires?

 Oh well, what do you expect from a smoker made in China
 

old sarge

Master of the Pit
OTBS Member
★ Lifetime Premier ★
2,887
657
Joined Nov 26, 2012
bird731713 - IF you decide to buy a new smoker, be sure to look over the line from Smokin-it, in addition to looking at the MES.  Smokin-it is more expensive but rock solid and dependable.  I am very impressed with the quality and performance. 
 

andypanda

Newbie
17
12
Joined Sep 10, 2010
Hi All. Just getting a chance to report back. The fix worked just like described above however I also still get an ERR2 when I turn on the unit.

The 2nd connection cracked apart while I was fixing the first so it was rebuilt as well. I crimped on a paddle connector tested the fit, slipped on some shrink-wrap to cover the wire connection and to extend down past the end of the paddle to cover the heating element contacts heated shrink-wrap up with a mini-torch and insulated and weatherproofed the connections.

Overall easy fix and now the unit is much-much faster to come to temp and I get good smoke from the smoketray.

Let the beast eat!!!
 

cmayna

Master of the Pit
OTBS Member
★ Lifetime Premier ★
3,548
1,225
Joined Jun 23, 2012
Awesome.  Glad it's back up and running.
 

rpfutrell

Newbie
1
0
Joined Oct 23, 2021
I know this thread is 5 years old, but it was insightful to the exact problem I am having on my MB20073519 The only problem is that none of the solutions worked for me.

I did leave it out in a few good rainstorms. So I only have myself to blame. I suppose the heat elements are completely gone.
I opened the covers made sure everything dry, solid connection, and still getting Err2
 

dr k

Master of the Pit
OTBS Member
2,806
667
Joined Mar 22, 2013
I know this thread is 5 years old, but it was insightful to the exact problem I am having on my MB20073519 The only problem is that none of the solutions worked for me.

I did leave it out in a few good rainstorms. So I only have myself to blame. I suppose the heat elements are completely gone.
I opened the covers made sure everything dry, solid connection, and still getting Err2
I believe I get the err2 from the meat probe two pin connector on the rear controller. I disconnect and bring it inside to keep it dry from condensing humidity. Sometimes it's fine if not then reconnecting for a solid connection. Pins slide in the connector and can get pushed back so I push them all the way in and glued the back of the connector and wires so pins are fully inserted and can't back out no more err2.
20210726_185136.jpg
 

Helen Ivy

Newbie
17
2
Joined Oct 2, 2021
I would call masterbuilt. They are pretty good about helping even if the warranty is up. You never know.
I find Masterbuilt to be SPECTACULARLY unhelpful myself. I tried for weeks to get their attention for my earlier issue. I got Error 2 and I've used it less than 5 times, hasn't been in the rain.
 

dr k

Master of the Pit
OTBS Member
2,806
667
Joined Mar 22, 2013
Go to their page on FB and messenger them. This is quickest to get a response. Have your receipt/order/model # picture and case # if you have one and send them. Mention any contact name you've been working with.
 

Helen Ivy

Newbie
17
2
Joined Oct 2, 2021
I have spent HOURS in the past trying to get them to address my issue. They just send me the same video over and over. At one point they said that someone would call me, but that never happened. I repeatedly messaged with the same person on the app and I also went back and forth with them over email for WEEKS. They did not feel like dealing with my issue so they did not. They didn't care.
 

IronDogJCH

Newbie
9
1
Joined Dec 2, 2021
This is looking like the same runaround I am getting. Bought my third MB unit, this one a MES40G bluetooth electric upright smoker. 3 hours into my 6-hr turkey smoke, I went to baste the bird and am presented with this ERR 2 display which, regardless of my actions, would not clear, preventing me from knowing if the thing was still on, holding temp, time nothing. Unplugging didn't help as immediately upon reconnecting to the AC showed this error and nothing would clear it from the display. The only thing I could find on error codes for MB smokers says something about the temp probe. The only troubleshooting suggested was to inspect the leads to determine if they were burnt or otherwise damaged. The inside of that particular compartment was pristine. The actual probe appears to be damaged, but unplugging that from the controller failed to resolve anything.

Of course, you can't get a human being to answer the customer service line. ll you get is instruction to fill out some online support request. Today I was delivered a useless message stating they were closing my request because it appears my unit is out of warranty and here's a parts page to find replacement parts. But as to speaking with someone to find the path out of this error code overriding any use, basically a "Go F... yourself. We don't really give a damn."

I was seriously considering moving to one of their Gravity Units. Now, not so much.
 

Helen Ivy

Newbie
17
2
Joined Oct 2, 2021
This is looking like the same runaround I am getting. Bought my third MB unit, this one a MES40G bluetooth electric upright smoker. 3 hours into my 6-hr turkey smoke, I went to baste the bird and am presented with this ERR 2 display which, regardless of my actions, would not clear, preventing me from knowing if the thing was still on, holding temp, time nothing. Unplugging didn't help as immediately upon reconnecting to the AC showed this error and nothing would clear it from the display. The only thing I could find on error codes for MB smokers says something about the temp probe. The only troubleshooting suggested was to inspect the leads to determine if they were burnt or otherwise damaged. The inside of that particular compartment was pristine. The actual probe appears to be damaged, but unplugging that from the controller failed to resolve anything.

Of course, you can't get a human being to answer the customer service line. ll you get is instruction to fill out some online support request. Today I was delivered a useless message stating they were closing my request because it appears my unit is out of warranty and here's a parts page to find replacement parts. But as to speaking with someone to find the path out of this error code overriding any use, basically a "Go F... yourself. We don't really give a damn."

I was seriously considering moving to one of their Gravity Units. Now, not so much.

EXACTLY my experience TO THE LETTER!

I have emailed me and constantly got that "we are closing your request" EVEN THOUGH I WAS STILL IN WARRANTY. THE UNIT WAS BRAND NEW OUT OF THE BOX. Many times I used the bot that's in the app and on the website, and that person refused to help me. I was told either by that person who is behind the bot, or via email. that I would get a phone call. I NEVER got the phone call. THIS WENT ON FOR WEEKS. Also, they kept sending me the same video in lieu of actually dealing with my question.

Now I have the same error message as you. I have used the smoker three times, new out of the box. It says the temp probe. I don't use the temp probe at all since I smoke pieces of salmon. It says something about the leads being damaged but this unit is NEW OUT OF THE BOX.

I would recommend that people NEVER BUY A MASTERBUILT PRODUCT. I WILL NEVER BUY MASTERBUILT EVER AGAIN, despite the fact that it is the main brand sold at my local Lowe's. I will drive elsewhere and buy a different brand. DO NOT BUY MASTERBUILT. THEY CLAIM TO HAVE CUSTOMER SERVICE, BUT THEY DON'T GIVE A WHIT ABOUT HELPING CUSTOMERS. They are awful. I went back and forth with them for WEEKS. They brushed me off and went back and forth with me for WEEKS rather than just help me in the first place. Their main occupation at Customer Service, whether via email or via the bot on the app or website is to spend their time refusing to deal with or help customers. They put an enormous amount of energy into NOT helping me. It could have been solved with ONE CALL, ONE PERSON taking ten minutes or less to deal with my issue. THAT NEVER HAPPENS. They do not care at all. Instead of helping customers via email or the bot on the app/website, MASTERBUILT WOULD RATHER EMPLY PEOPLE TO SPEND A HUGE AMOUNT OF TIME AND ENERGY DODGING CUSTOMER SERVICE ISSUES.
 

dr k

Master of the Pit
OTBS Member
2,806
667
Joined Mar 22, 2013
I bring the controller inside in between smokes and got the err2 meat probe error. I checked the pins on both wire connectors and one from the two pin meat probe connector was loose and wanted to back out of the connector. I pushed the pins into the connectors and glued the back of the two female and two male connectors to the wire insulation so they can't be pushed back while connecting. No problems the rest of the summer. Maybe heating and cooling. Or something created a loose pin. Worth a check. Not much lead on the two pin coming out of the smoker to work with vs the five pin in the pic.
20210726_185136.jpg
 

Latest posts

Hot Threads

Top Bottom
  AdBlock Detected

We noticed that you're using an ad-blocker, which could block some critical website features. For the best possible site experience please take a moment to disable your AdBlocker.