AVOID Chaney Instruments (ACCU-RITE) Digital Wireless

Discussion in 'Meat Thermometers' started by ms mayhem, Jun 4, 2008.

  1. ms mayhem

    ms mayhem Newbie

    About 7 months ago, I purchased an Acu-Rite 00993ST (wired) for cooking in my smoker. I have used the product less than 2 or 3 times.
    Since I have purchased the thermometer, the magnet has come off of the back, and now the probe display reads *HI*. I have read the FAQ on their website which tells me that I have to purchase another probe.

    I wrote them to say that I will not purchase another probe, and I will probably not purchase an Acu-Rite brand thermometer again due to the lack of quality. (I know that it''s an inexpensive meat thermometer, but it really irks me that something that should just work... doesn''t after 2 or 3 uses)

    Within a day, I receive a prompt and courteous response from their customer service apologizing for the unit, and a notice that they will be sending a better unit that they know will work.

    I received a brand new Wireless Accu-Rite (Model 00869). Guess what, The new "main" unit doesn't even power on. We tried 3 sets of brand new batteries just to be sure. Customer service may be spot on, but quality assurance is....wow.

    Now, our cheap Redi-Chek by Maverick is doing great. It's just as good as the day we got it. (This is what I use: http://www.amazon.com/RediCheck-Remote-Cooking-Thermometer-Settings/dp/B0000AQL24/ref=cm_cr_pr_sims_i )

    My two cents...
     
  2. white cloud

    white cloud Master of the Pit OTBS Member

    You may want to check the batteries even if they are new. Also lay your probe out in the sun for a day, it may have moisture in it. But I know what you mean about buying crap.
     
  3. fred420

    fred420 Meat Mopper

    buy a charmglow remote from h depot--$15.00.. you will love it..
     
  4. rodbuilder

    rodbuilder Meat Mopper SMF Premier Member

    I have 3 of them and they work great. Never had any problems. I take my remote to my shop which is about 80 ft away from where my smoker is with a free standing garage between and not problems receiving a signal.
     
  5. richoso1

    richoso1 Smoking Guru OTBS Member SMF Premier Member

    I'm with White Cloud on this one. I've had strange readings on "new" batteries. I now only use rchargable batteries, luckily they fit my charger that I use for my camera batteries.
     
  6. 7outof10

    7outof10 Meat Mopper SMF Premier Member

    i got an acu rite and have used it 2 times wiht no problums
     
  7. 7outof10

    7outof10 Meat Mopper SMF Premier Member

    but im going to get a cupple of thoses remort ones put one in the meat and one in the smoker .....that is assumiong that they will read that high i hope
     
  8. crewdawg52

    crewdawg52 Master of the Pit OTBS Member

    Got 3 Accu-rites and they all work very well. Yes, they were only $15, but take care of them, and they will take care of you. I recommend them to anyone.
     
  9. dmack

    dmack Smoke Blower

    I don't know if my digital is an Accurite or not. It was a cheapy from Walmart. Anyway my unit didn't work with brand new batteries. I noticed that one of the batteries was not making contact on one end. I put a folded up piece of foil in and it has been working since. I know I shouldn't have to do that to a brand new item. But, hey, it works. Give it a shot.


    dmack
     
  10. safety1

    safety1 Fire Starter SMF Premier Member

    I had the exact same problem with mine. I did not get the same response from cusotmer sevice though. I was told that this was due to "mis-use" and that they would not warranty the purchase. Used twice and got the "HI" reading as well. Tried new batteries, tried a hair drier thinking maybe some condesate got into the wires, and let it set out on the counter for a couple of days, no change. I promptly discarded the piece of garbage and got a Weber #32908 at our local hardware store. Works like a charm and is very accurate.
     
  11. oillogger

    oillogger Meat Mopper OTBS Member

  12. flash

    flash Smoking Guru OTBS Member

    Me too. When the probes finally burned out, I emailed them and they sent me two more......FREE [​IMG]
     
  13. tn_bbq

    tn_bbq Smoking Fanatic

    I have an Accu Rite probe thermometer. It's hit or miss. I get false readings with that thing every once in a while. I simply put it away and try again in a few hours. I have several other thermometers so it's not that big of a deal, but it does irk me.
     

Share This Page