Internal Thermo reading high??

Discussion in 'Poultry' started by nrok2118, Jul 8, 2010.

  1. nrok2118

    nrok2118 Fire Starter

    Hey all, I just put up a thread in the charcoal section since this is my first time smoking with my Weber Smokey Mountain.  But I figure Id get some more knowledge here. 

    Problem is Im cooking some chicken quarters and the thermo probe is reading high.  I tried two different probes in multiple spots in multiple pieces but always got an internal temp around 120 fresh on the cook straight from the fridge.   At this point they have been on cooking at 250 for about 30-45 min and its reading 151?!  any help is appreciated!!
     
  2. Make sure your probes are not touching any bones. Also did you try calibrating your thermo's?
     
  3. nrok2118

    nrok2118 Fire Starter

    Yeah i tested both with various tests to ensure accurate readings, Im thinking it must be a bone thing but i tried multiple times to get it into a thick part of meat, hopefully i just suck.  Im gonna let them go for a bit and flip them and try to find a better spot for the probe
     
  4. jirodriguez

    jirodriguez Master of the Pit OTBS Member SMF Premier Member

    You either got a bad probe... or your probes got washed/submerged in water. First time I had a probe set up I washed it in the dishwasher.... after that it would read 140° just sitting on the table, bought new probes and works fine now.

    Since you have the WSM the lid therm is actually accurate - amazing, a factory therm that actually works! lol. Just keep your lid therm around 250° then if you have a quick read meat thermometer you can check the internal temp. on the chicken after about 2 hrs. I find 2-3 hrs. is average for leg quarters with my WSM running at 250'ish.
     

Share This Page