or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES Not producing smoke
New Posts  All Forums:Forum Nav:

MES Not producing smoke - Page 2

post #21 of 29
Quote:
Originally Posted by Stewie-Q View Post
 

The AMNPS is always on the bottom rack with plenty of air flow 360°

I've gone so far as to completely remove the chip loader to achieve maximum oxygen flow

Top vent is wide open

I've used a variety of pellets from the ones provided by AMAZEN to some that I've gotten from Academy (for pellet smokers)

With my limited experience with the AMNPS, the only other thing I can add is to be sure your MAZE or Tube is well lit as mummel & Bear said in the two posts above this one. 

post #22 of 29

I'll get a video posted next time I pull out the MES

I use a Benzomatic Propane/MAPP torch to get my pellets going.  I achieve a nice glowing bed of coals on both ends & I blow like hell on both ends to ensure its properly lit.  I don't think the issue is with the AMNPS but with a lack of oxygen flowing through the MES.  

Cheers!

Scott

post #23 of 29
Quote:
Originally Posted by Stewie-Q View Post
 

I'll get a video posted next time I pull out the MES

I use a Benzomatic Propane/MAPP torch to get my pellets going.  I achieve a nice glowing bed of coals on both ends & I blow like hell on both ends to ensure its properly lit.  I don't think the issue is with the AMNPS but with a lack of oxygen flowing through the MES.  

Cheers!

Scott


That's what everybody says when they first start trying the AMNPS---So did I.

 

Mine is never ready to go in 10 minutes. When I think it's ready I blow on it some more. I let it go out 6 or 8 times & blow deep into the coals until it lights up on it's own. Then I blow through the flames some more (Being careful to not inhale any flames or heavy smoke)

 

Once it's lit properly, you can't even put it out on purpose without completely separating every burning coal from the rest of the unburned pellets.

 

Bear

post #24 of 29

It takes my smoker approx 20 minutes to heat up, so the last time I used my Tube, I lit it and made sure it was going to stay lit prior to turning the Smoker on, so I would estimate my Tube was burning between 20-25 minutes prior to putting it into the smoker. It smoked well with the JD pellets, especially considering they don't smoke well to begin with. I will be trying the Hickory and Mesquite Pellets shortly as the word is that  they smoke well.

post #25 of 29
Quote:
Originally Posted by Squirrel View Post
 

I wonder if some of these companies read what we post. I mean, I would trust what you guys tell me about a product and their customer service over any review I read. Well, I didn't pay attention when y'all said to stay away from that GAWD AWFUL FOODSAVER but, lesson learned!

 

Glad to hear that fella Darryl stepped up to the plate. We need more folks like him taking care of customers!

What's this about the Foodsaver?  My wife and I have had one for several years that does a bang up job on our smoked cheese, pulled pork, pretty much everything we use it for.  Was there a certain model or that brand overall that we should have avoided?

post #26 of 29

Emailed Todd and he gave me this piece of gold:

"

Place the burning AMNPS 5x8 on the rails to the left of the chip pan housing

Pull the chip pan out 1 ½”

Pull the chip loader out 2”

Exhaust WIDE open

No water in the water pan"

Will give this a go next time. 

 

Thanks for the advise guys. 

SS

post #27 of 29
One more thing to check with the Gen 2.5 BT is the small drip hole on the floor of the unit. If you cover the flat tray with tin foil, make sure you punch open the hole in the tray. Otherwise you block airflow from the hole. I've used my smoker three times now with the AMNPS with no problems. Salmon and veggies set for this Sunday so we will see if all goes well again.
post #28 of 29

I thought about that hole again, however, the times it's lit properly and worked, the hole has been sealed with foil anyway.  So I dont think airflow is a problem.  Its got to be the initial lighting.  Hair dryer here I come. 

post #29 of 29
Quote:
Originally Posted by id2nv2nj2ca View Post
 

What's this about the Foodsaver?  My wife and I have had one for several years that does a bang up job on our smoked cheese, pulled pork, pretty much everything we use it for.  Was there a certain model or that brand overall that we should have avoided?


I had a Mini Foodsaver that only did the 8" bags that lost the sealing ability after 2 years but I needed an upgrade.  The 3120 series with the auto close would close on one side and jam on the other and would need to be taken apart to turn the gear backwards manually to unstick.  I returned 2 of these that were normally $120 but on sale at  $28.  I just kept returning them till I got one with a good closing feature.  It has a wider sealing strip.  I get my bags from Vacuum Sealers Unlimited,  one of the SMF sponsors shown at the bottom of the page.  The mesh center strip really pulls meat juices to the center when vacuuming.  They work great and are about half the price of Foodsaver rolls.  I'll always have a vacuum sealer.

-Kurt    

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES Not producing smoke