SmokingMeatForums.com › Forums › Smoking Meat (and other things) › Pork › Having a rough start with my pulled pork smoke!!
New Posts  All Forums:Forum Nav:

Having a rough start with my pulled pork smoke!! - Page 2

post #21 of 24
Quote:
Originally Posted by pandemonium View Post

i always get them wet but not soaking in water guess i better quit doing that if its not too late



I usually just take a wet mildly soapy sponge scrubber and give them a good wipe down.... but I hold it so the probe is up and the wire is trailing down. That way any water doesn't run down into the probe. Quick rinse, dry with hand towel then good to go. Haven't had issues yet.... other than that first probe I screwed up.... lol.

post #22 of 24


 

Quote:
Originally Posted by Venture View Post

DeanNC

 

If Maverick won't take those probes back and replace them, maybe you could make a deal on your wife?  LOL

 

The thought crossed my mine! lol  I'm just glad I got a hold of Maverick today and they're sending me a new probe...it saved me from a predicament I've been pondering....just how I was gonna break the news to the wife! hehe 

 

pandemonium - hope it all turned out good!  I've had those Wally World beans and they aren't to awful bad...especially when hungry! lol

post #23 of 24

I use Thermoworks probes.  They are wonderful.  Their cleaning recommendation is to use antibacterial wipes, which I do.  The thermo will act a bit funky for a few minutes after because of the cooling effect of the evaporation from the wipe.

post #24 of 24

Hey Pandemonium,

Sounds like your doing alright again. Gonna have to get those thermo's squared away!

 

If you didn't have any problems, you'd have to change your Member Nickname!

 

 

Bear

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Pork
SmokingMeatForums.com › Forums › Smoking Meat (and other things) › Pork › Having a rough start with my pulled pork smoke!!