or Connect
New Posts  All Forums:Forum Nav:

Need Some help guys

post #1 of 5
Thread Starter 
I am getting ready to do a Pork Loin for the super bowl and My MasterBuilt wont heat up. It keeps reading EAAF on the Digital Control Panel. I dont have a clue what is wrong with it . Worked fine the last time I used it. Its been snowing here and we have about a foot of snow but the smoker is under a roof outside. Anyone got any ideas on what the problem is and if I could give it a quick fix to save the smoked loin for the super bowl?
post #2 of 5
Try taking the controller inside to warm up or place a warm towel over it for a while. There is a known problem with the controller in cold weather. Many post here on the subject.
post #3 of 5
After you have warmed up your controller.

Plug it in, set temp, and time, then turn it OFF.
Unplug the electric cord from outlet, wait about 10 sec. Plug elec. cord
back in outlet.
Turn on MES and reset temp and time.

If it still has the error. Try the same Hard Reset procedure again.
You may have to do it three times. If the problem still persists you need to contact Masterbuilt.

If you are using an extension cord, eliminate it during these test procedures.
post #4 of 5
There's some kink in the engineering of MES that it won't run below 40*F.

I put a "Trouble Light" inside my unit to get the temp up above 40*, and bring the controller inside to warm up. Once it all gets above 40* you're good to go!

I know it works, cuz it was 20* outside this morning when I put (2) slabs of bacon in at 6:00am.


No Creosote! A-Maze-N Smokers

post #5 of 5
Thread Starter 
I just put it in my garage and let it warm up and tried it and works again. Thanks alot guys.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers