or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › not getting enough smoke flavor out of my MES
New Posts  All Forums:Forum Nav:

not getting enough smoke flavor out of my MES

post #1 of 6
Thread Starter 
I did some ribs last weekend and they were cooked perfectly, but I'm just not getting enough smoke flavor out of the MES for some reason.
I'm using mesquite chips, I'm loading the hopper up every hour or so.
Do you think it could just be some bad wood? It seemed like it was great the first few times I used it and it's slowly getting worse.
post #2 of 6
I can think of a couple of reasons this may be.

I don't see where you are from, but if it was cold when you started with the MES, it would be "on" more heating up, so would generally smoke more if you had wood still in it. The warmer it gets outside the less it has to turn on to keep to temp and so would not smoke as much maybe.

Another possible is that when you were "new" with the MES, you were a lot more hyper about it and were putting wood into it more often than every hour. I find that sometimes I can go an hour with a big chunk, but generally it's more like a half hour if I'm using chips.

And that brings up another possibility. Maybe you were using bigger chunks of wood before so they lasted longer than the wood you're using now, or maybe it was greener/wetter than it is now so lasted longer.

And of course, it could also be that as you've been smoking more, you've developed more of a taste for smokier food just like it seems that people that eat peppers tend to like them more and somewhat hotter as time goes on.

Just letting my mind wander (gets easier and easier every year! PDT_Armataz_01_12.gif ), you could also try using a different wood. Mesquite is pretty strong though. But you could try hickory which is pretty robust and can be pretty smokey without making things taste bitter.

And...have you changed your rub? That could also be something to look at.

I'm sure there will be more folks to help out too but maybe some of these will give you an "oh yeah, that might be it". Good luck and keep on trying it!
post #3 of 6
i also use the mes and i add chips about every 20 to 30 min the first few hours. then taper off towards the end.
I enjoy my mes but it will never have the same smoky flavor as my wood / coal burner.

Also could be the ribs. different batchs of meat can cook way different from each other.
post #4 of 6
Thread Starter 
Yeah, maybe I was not adding them often enough.
It's been a but warmer than the last few times I ran it.
I put one lump of charcoal in the pan to try and produce a smoke ring, all I had on hand was match light charcoal and I swear I could taste the match light chemicals in the meat.
post #5 of 6
You did, yuk. If you want to try lump get true lump and not briquettes. BTW, don't worry about the smoke ring, can't taste it anyway. Just enjoy the flavor. Also try switching to chunks instead of chips. You may have to split them, but is cheaper in the long run.

Good luck,
post #6 of 6
You have to put small frequent amounts of chips in to it to get the smoke flavor.

You could also check out pignit's most recent mods for the smoke!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › not getting enough smoke flavor out of my MES