or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES First Smoke and Temp issues
New Posts  All Forums:Forum Nav:

MES First Smoke and Temp issues

post #1 of 4
Thread Starter 
Hey folks. Omaha checking in with First Smoke.
Bought Masterbuilt Electric Smokehouse at Cabela's for $149 last Wednesday. Thursday did a seasoning for 3 hours set at 275 and put in hickory chips last hour. No problem coming up to that 275, and maybe took 1/2 hour to get there. This was on a cool evening and was maybe 40F outside.

On Sunday did 5.7 lbs of extra meaty babybacks. No wind out side and temp was 40-43 degrees F. Started about to pre-heat at 11am, but didn't realize that I needed the timer set to get it going, so got started a little late, but once I realized, I just put in the pork without pre-heating about 1145. Water pan filled a little over 1/2 with hot water. I had very little smoke escape from the unit door, and everything seemed to be well sealed.

After 1/2 hour and again at an hour the temp just wouldn't get up. I think I maxed at a reading of 210. After about an 1 1/2 hours I dropped a temp probe through the top air damper, and it read 250. So after playing with it for the next 1 1/2 hours, I found that setting the MES to about 177, got me an average temp of 225 on the external thermometer, with a range of 215-235. I basically went for the 3-2-1 and even with the issues trying to figure the temp out, I ended up with pretty good raves on the ribs, with the meat pulling off the bone cleanly without it just falling off. I used 1/3 hickory, 2/3 apple soaked. Foiled about 2:30, Pulled out about 4:30, put on a light coat of a simple bbq sauce and put back in for another hour. Let set for about 20 minutes covered and dug in.

My question is should I be worried about the temperature issue, or just depend on my own thermometer? (I'm even thinking of a second one for the meat itself and just extra assurance). Problem at the time is that with such a variance I didn't know if my external thermometer or the MES unit was the one with the most accurate temp. After eating, I took everything out of the MES and cranked it to 275 and and the cooker read 285 after about 1/2 hour, with my probe reading 350.

I can only assume the water and amount of meat had some impact on the temperature. I did mess with the air damper, and this did help it come up to temp quicker, but the unit never did get to a reading of 225 (but the external did). Unit generated plenty of smoke and I think pretty early in the heat process. Any reason to think this unit has a problem?

Thanks for all the postings to date. Nice site. I was going back and forth between the MES and a Cookshack, but thought I should go the lower dollar route as a first smoker.
post #2 of 4
I don't have an MES, but I do know that most thermometers that come on the smokers are not accurate. It's always best to have a good external therm such as the ET73.
post #3 of 4
Well I am certainly no expert in this field. But what I have heard time and time again is to go by the INTERNAL temps of your meat and not the amount of time its in the smoker. By all means, get yourself a good thermometer. I as well as alot of others here use a dual probe digital. One for the smoker temp and the other for the meat. You can get an idea of how long it will take something to smoke based on past smokes, but go by temp, not by time. Hope I helped.
post #4 of 4
Get yourself a Maverick remote monitor and use it. Covers both meat and smoker temp. Do not count on the MES gauge, a mistake I learned early off.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › MES First Smoke and Temp issues