or Connect
New Posts  All Forums:Forum Nav:

First Smoke

post #1 of 6
Thread Starter 
Well I'm trying my 1st smoke with my SNP just a couple of Fatties to get the hang of things, everything was going good the the smoker started cooling of It appears to have plenty of lump and I opened the vent up but it doesn't seem to raising the smoker temp,

Should I add more lump?? or do I want to close the stack up some ???

If I need to add fresh lump do I need to light it with the chimney first???
post #2 of 6
Is the grate your fire on high enough up? Don't let the ashes choke out the fire.......you need good airflow for things to work
post #3 of 6
Thread Starter 


The grate is plenty high enough there's no ashes against it.. I'm using a grate I made out of steel thats full of 1/4" holes and it seems to be getting air,
post #4 of 6
Well, if you had a good temp but it started dropping, but no ash build up, and assuming nothing else has changed.........I would say to add more charcoal.........I would start it before adding since you are having heat problems..........

Falling temps are almost always air flow problems (in my experience anyhow), make sure you got firebox vents open...........

Hopefully someone will come along that can help you..........I am just kind of sitting here scratching my head.

You could try closing the stack some, but general advice is to leave the stack wide open to avoid possible creosote problems.
post #5 of 6
Thread Starter 

Finished pictures

Well here's the finished product, It took a little longer then I planned but It sure was good....
post #6 of 6
You ever get the heat problem figured out? I am assuming not since I saw your other post with the baffle question. Is there any restrictions between the firebox and the main chamber..........should just be one big open (although maybe not big enough) opening.........your baffle should not restrict that opening.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Charcoal Smokers