or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Electric Problems w/ Masterbuilt
New Posts  All Forums:Forum Nav:

Electric Problems w/ Masterbuilt

post #1 of 9
Thread Starter 
Hello all,

I have a question about a Masterbuilt Electric smoker. It has been used only about 15 times, and last week, while attempting to smoke a chicken, everything shut off. The digital timer and temp on top does not do anything and the heating element does not come on.

I am figuring that the element is bad, and needs to be replaced, but would the element going out cause the digital timer and temp to stop working. I am wondering if the element goes out if it shuts down the electric to the control panel?

Anyone have this experience before, and do you have to get the element from masterbuilt or is there another source for the element.

Thanks in advance....
post #2 of 9
Don't have one of these, but it seems real likely the element dying would open the circuit to the controls. They most likely feed off it.
You didn't let the smoke out of any of the components did you? If you did they are no good. PDT_Armataz_01_29.gif
post #3 of 9
you need to contact masterbuilt on this issue directly. For me, I don't think it's the element, it sounds more like a transformer issue to me.....however in some cases if the element goes it could take other things......
post #4 of 9
Masterbuilts customer service is top notch, I have nothing but good to say about them. Me and friends have had great experiences.
Just last weekend a freind purchased a Masterbuilt went to fire it up and after firing it up it would shut down and the screen woud read EEAF. He got a hold of me wondering if there was something he was doing wrong and we decided it was the screen most likely. He called Masterbuilt and they were shipping him a replacement screen on Monday.

Personally they upgraded 2 of my old styles and also upgraded 2 of my freinds old styles into the new styles, no charge. All because of the magnetic door seal on the old style.
post #5 of 9
You might try unplugging the control box from the main smoker and reinstalling.....if this does not help call customer service pdq and they will take care of you I'm sure
post #6 of 9
Sounds more like the temperature controler to me. If the elemet goes bad you should get an error reading no?
post #7 of 9
I had a problem with mine not heating but my electronics were working . I took mine apart and the terminals that plug onto the heating element were no longer there , they were gone , so I bought some appliance terminals ( which I believe are stainless steel ) and put those on the wires and plugged those on the terminals of the heating element and since then it has worked fine . I realize this isn't the same as your problem but I thought maybe some one else may have this problem . I originally thought my element had went bad but support told me they usually don't go bad . I was past the 90 days so no warranty but support said before I order a new element check it out first to see if that was the problem and it wasn't , it was just the terminals on the ends of the wires were gone .
post #8 of 9
I suggest Roll Call to ya - http://www.smokingmeatforums.com/for...splay.php?f=47

Sounds like you know your way around a Masterbuilt and we want to welcome you to SMF and hear of your past smoking history !!!
post #9 of 9

Wow, seven years later and it was the info I needed. Thanks it made my day to get my smoker working.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Electric Problems w/ Masterbuilt