or Connect
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Strange taste with new smoker, HELP!!!
New Posts  All Forums:Forum Nav:

Strange taste with new smoker, HELP!!!

post #1 of 44
Thread Starter 
Got my new Masterbuilt Electric, looks like an awesome piece of equipment! (But that's a topic for another thread...)

Smoked a fattie the night I got it, and the fattie has a strange taste. The wife thinks it tastes like a burnt grease flavor, I agree, but think it's more of a toasted marshmallow taste! I was wondering if it has to do with how fast the wood is burning?

With my old gas Brinkmann, we didn't get that strange flavor, just smoke flavor. I would soak my chips (which I didn't do before I made the fattie), and on the Brinkmann I would wrap my chips in foil and put them in the smoker. I could smoke a turkey for 10 hours, and the chips would still have some brown on them, they wouldn't be totally burned through. But with the new Masterbuilt, it takes about an hour and the chips are totally burned black.

Am I getting a weird burned flavor because of how fast the chips are burning? Do I need to soak them and use less chips? It seemed like I went through a lot of chips just to do a fattie.

I also didn't run the smoker with chips first before I smoked the fattie, but I don't think that's the problem, because I done some cheese the next day and it tasted the same.

Anybody have any ideas? This thing is too cool to make everything taste nasty!
post #2 of 44
I certainly think not curing your new smoker did not help
There are manufacturing residues in there, at least my masterbuilt had them

I would give it a good curing even if you have used it before
If it smells like creosote inside you may have to clean it before you cure it

The first, second, third, fourth, fifth and sixth lesson I had to learn with mine was to cut way back on the wood. Just 2-3 little pieces (chips) every 30-45 minutes is plenty
Soak em good all but one per fill if you like
If that still doesn't please you try making a foil pouch and stick it in via the tray
post #3 of 44
Thread Starter 

Re: Strange taste with new smoker, HELP!!!

Wow, 2-3 chips per 45 minutes? Are you talking about the really small chips, mine are small, maybe the size of a dime or nickel?

I think for a fattie (3 1/2) hours, I pretty much FILLED the wood inserter 3 times!! (What would that be, 200-300 chips per hour?) Sounds like I'm oversmoking really bad. I'll clean it real good tomorrow, and then run a cycle for a couple of hours without any meat in it.

Illini, I'm sure glad you're on this board to help clueless newbies like me......
post #4 of 44

Re: Strange taste with new smoker, HELP!!!

:P Holly Toledo :P Thats an ENORMOUS OVERKILL
Clean it out and do a slowanlow smoke cure for 2-3 hours
I think you have the new vented model, how big a cloud of smoke did you have?

If you think you don't have enough smoke coming out then that's just about right wink.gif
post #5 of 44
Thread Starter 

Re: Strange taste with new smoker, HELP!!!

I do have the new vented model. It seemed like it smoked pretty good for a little bit, then the wood would be burned up and the smoke would be stopped.

How do you set your vent when smoking? I think I had it about halfway open....
post #6 of 44
My advice is keep the top vent about 2/3 open and close it down some if the heater is on (red light indicator) more than 50-60 percent of the time.

The two things to remember are the more the heater operates the faster the wood burn and the creosote problem arises.

A very small amount of wood (2-3 chips) at 30-45 minute intervals works best for me.

In cold weather my top vent is hardly open and this means very little wood is needed.

When you have it right you will think that there is not enough smoke. If you see white smoke at all you are overdoing it

If I can't see smoke but can smell it it's just right
post #7 of 44
Thread Starter 

Re: Strange taste with new smoker, HELP!!!

It's really strange, but my wood just burns up too fast.

I smoked for 2 hours last night without any meat, to condition the inside of the smoker. I soaked my chips for about 3 hours, and only put a few in the smoker. Set the temp to 250. But the chips seem to totally burn up too quickly. At one point I put some soaked chips in, there was 9 minutes left until the unit turned off, and when I looked a bit later, the chips were totally black and burned up! Soaked and only heated for 9 minutes!

It almost seems like a design flaw, the chips in a metal box, sitting right on top of the heating element. So they just burn up too quickly. Frustrating........

I even tried to simulate what I used to get with my gas smoker, I put the chips in a foil pouch and placed them on the bottom of the smoker up under the element, but there they wouldn't even get hot enough to smoke...

Did I mention, Frustrating.........
post #8 of 44
Please give me some data since you have the new model and I have not seen it.

How many inlet air holes in the end of the wood tray?
What is their diameter 3/8" 5/16" etc (Find the size of the largest drill bit that will slip in the hole). Does the tray seal the hole when pushed in?

What is the namplate wattage for the heater?

Have you checked the internal temp with a GOOD thermometer against the units indicated temp? (IMPORTANT)

What is the top vents open area at max in square inches approximately? If it is a butterfly wheel just add the 2 triangles together and give me the dimensions of the resultant square

Is the door seal leaking? (smoke coming out around the door).

When you are at 250* is the heater cycling off any at all? (red indicator light goes out)
Why are you trying to maintain 250*?
275* is supposed to be max that it can be obtained on mine
What does your manual say about max heat setting?

What are the size of the chips you are using? Average LxWxThick

Do you have a removable metal roof over the wood pan area or is it open on the top side?

Each question needs an answer since any or all could effect your problem!!

I am simultaneously working with more new owners so if I get you confused just tell me which model we are working with!!

BTW if you try a foil pouch it needs to go on the tray and be dumped normally. It will just keep some heat from the chips there.
When my chips are consumed they are grey ash powder, not black pieces
post #9 of 44

Re: Strange taste with new smoker, HELP!!!


I just got one of these new smokers also and listened to illini. Just took the first trial of two small pork loin roasts out and tasted a small corner and OH MY GOD......awsome. Not sure about the funny taste you are having outside of not curing the smoker and maybe too much smoke. I already discovered that illini was right and I cut wayyyyyyy back on the amount of chips I was using. Other things are before I even cured the smoker I set it at 100 deg and let it cook off the manufacturing oils for 30 mins, then I ran it at 225 and cured it for 5 hours before this trial run. I kept the damper set at 1/3 open for the curing and basically this entire smoke period as well. The chips ended up a grey ash as they should and not just black chips.......so it's possible that you may have something wrong with yours......
post #10 of 44

Re: Strange taste with new smoker, HELP!!!

Thanks smoked
Glad to hear you are up and running :?
Maybe together we can help JR.S get up and running too!
post #11 of 44

Re: Strange taste with new smoker, HELP!!!

well I decided to go ahead and pull the pork loin roasts and mix them with my homemade bbq sauce.....made AWSOME pulled pork sandies......nothing left!!!!! So it didn't take much convincing on the little ladies side to get me to start the extremely long and labourious proceedure to make homade pastrami........so have two roasts all brined up and started on their weeklong journey of prep to making some of the most awsome pastrami ever consumed (or minus the last rub and smoke.....corned beef!!!)!!!!!!!
post #12 of 44

Re: Strange taste with new smoker, HELP!!!

Everyone here loves food porn (pictures) so post some of your smokes!
That will do us masterbuilt's proud wink.gif
Just pick out the relevant subject area an post away :) :)
It sounds like you are on your way to conquering your electric :!:
post #13 of 44

Re: Strange taste with new smoker, HELP!!!


How is it going....any info yet.....can we be of further assistance? :?
post #14 of 44
Thread Starter 

Re: Strange taste with new smoker, HELP!!!

Illini, hope I covered everything, here goes:

3 inlet holes in the wood box, 1/4 bit fits snug, holes are not closed with wood tray in.

650 watts on the nameplate

Checked temp last night with a pretty new thermometer, it said about 200-225 when the smoker was set at 250, so it might be a little off, but it's cooler, not hotter.....probably need to check again.

Vent on top has four holes, when fully opened the holes are approx. 7/8" long by 7/8" wide.....not exact, they are shaped like butterfly wings....

Yes, some smoke comes out the door, the manual says this is normal.....

Yes, I think it cycles off and on some at 250 or 225 whatever temp I set it at....don't know how much it goes off and on, max temp on mine is also 275......

I think the chips are average, some the size of a quarter, some smaller.......got them a Wally World.....

There is a metal roof over the wood compartment, but it's not removable, it's permenant.....

Did I miss anything????

Now, to the present. I smoked a chicken last night, and it turned out a lot better. I cut way back on the chips, but I still used more than you do, but not much. And yes, looking at the wood tray this morning, they mostly burned down to a gray ash. I still got a little bit of the strange burned taste, but it mostly on the skin. It seemed like the smoke coming out smelled (and made me smell like) burned grease rather than smoke. The water pan was full, but maybe I also need a little bit of water in the very bottom of the smoker so that the dripping grease don't burn?

Although the dark meat was delicious, I think I need more smoke on the white meat. (I do realize that the white meat don't ever have as much smoke flavor as the dark.....)

I'm a little disappointed that I can't just load up a foil packet of chips like I could with my old gas smoker and let it go. I was thinking this new electric would be a 'set it and forget it' sort of thing. It really burns through the chips fast, I even soaked them for a day. Trying to find a place to put a foil packet, put one last night on the two metal rods that go side to side under the wood try, but they never got hot enough to smoke. Can't figure where else to put them closer to the element.....

I'm wondering if I'm putting my wood tray in correct, it's screwed up and really hard to push in. My wood tray has a thin piece of sheet metal on the bottom, does it go above or below the heating element? It seems to fit the best below the element, but would certainly not heat the wood chips as fast if it were above it......

I think I'm getting closer, the amount of wood chips is a big difference maker....any advice is always appreciated.
post #15 of 44

Re: Strange taste with new smoker, HELP!!!

one quick question.....how much grease are you getting out of the unit in the grease tray on back? is the bottom pan put in where the small hole is facing the back of the unit? (seeing as this is the hole that lets the grease out into the outside pan)....... I know so far I've not had any grease, but then again have not smoked anything that had a significant amount of fat either that would cause that......but it's just a thought that maybe that could be giving you the burnt grease smell and taste. also don't forget that they reccomend to clean the door seal after each use as well......so far mine has yet to smoke out of the seal........

as far as the chip pan, yes it's a bit tough to get in, the pan itself should sit on top of the burner, the plate on it should be right below the burner (this by design to keep stuff from jumping up off the bottom of the unit and hitting the burner itself, plus helps force the heat upwards as well.....as illini said earlier, you can put the chips in foil and load them exactly the same as you would the chips by themself......you may want to try that also..... another thing is if your grease pan is not filling up and the bottom tray is in correctly it's possible that the drain hole is plugged......

the only other thing that comes to mind is if your chips were still green.....taking note that you got yours at wally world....I grabbed a couple of bags there today both of hickory and mesquite (and hell at 1.97 a bag it's a no brainer....even the chunks at 4.97 a good deal but just too damn big for these smokers).....from the bag I opened of the hickory they look fine and dry........ it's a small possibility that maybe you got some of the plastic wrap from the original packaging of all the parts on your heater coil also.....now that would give you a really nasty taste and nasty nasty smell.....nothing worse then burning plastic smell.........
post #16 of 44
Becoming apparant that your design on the new model is somewhat different than my older version....the 3 inlet holes at 1/4" or so is the same'...650 watts is not mine is 1800....The internal temp at the middle rack should be very close to the indicated temp on your electonics box...being low is puzzling maybe you should check again... use a meat probe run the cable out the bottom of door seal... make sure the probe does not touch the rack...stich it through a small potato and let the tip of the probe be exposed to the internal atmosphere....Cut way back on how much water is in the pan a 1/2 or less is plenty.....
while trying to heat this mass of water you are consuming too many chips.....let the red indicator light go out before adding chips the first time....only use chips until the internal meat probe in the chicken or pork or whatever you are cooking gets to 140*....then you need...no more chips just finsh the cook....Use apple chips for a milder smoke...add just a percentage of the mesquite or hickory to the apple.....

THROW the CHIPS you have in the TRASH and buy another brand such as Kingsford at a different store

See if you can find some apple chips you will like them better.

My older version does not drain into an external grease pan what reaches the bottom tray of the smoker just ends up looking like burnt drippings in you kitchen oven....dont think this is your problem

So for your next try:
Use less water and put it in the pan hot
preheat the smoker for 30 minutes before putting the meat in
Top vent should be 1/2 - 2/3 open
Use another bag of chips...apple?
stop adding chips when meat reaches 140* internal
Buy a meat probe with a cable and use it

Masterbuilt will replace any part you complain about
like the wood tray and door gasket seal

The seal can be a problem if you do not manage it properly.. it should contact the box the full width of the seal on all 4 sides and like smoked said clean the thing after each use.....wipe mine down with wet paper towels or use a rag


And no its not a set and forget deal.....you have to keep adding chips and drinking beer for the first few hours....ITS THE CODE!!
post #17 of 44
I double checked mine since I have the new version also..... the holes are 7/32'nds (so yea, basically 1/4"), the back plate on mine also states 650 watts, but I'm sure I saw on their site that say's it's 1000 watt element....but you never know what they are really saying on the back plates!!!! I'll have to double check temp on mine with the potato method you talk about....but I'm sure it's fine. I do have to say one thing....burnt drippings in my oven definitly make a bad taste in the food...... :D I'm thinking if it's not his grease pan then it's the chips are green (and we know that will make everything taste bad) and as I said I picked up some of the same chips he had...they seem fine, but not smoked with them....personally I usually use the kingsford brand myself....or something is on his element like some burning plasitic.....which not only will taste bad but also cause health problems.....
post #18 of 44
I had a senior moment....the old version is 800w not 1800w...just looked

I think the problem is boiling down to bad chips....too many chips....wrong wood choice...or a combination

I clean the racks and bottom drip pan each time with a high pressure washer and have no problem

waiting for JR.S reply
post #19 of 44
well I've got some of the wally world hickory chips soaking now, and a couple of rounds of jimmy dean thawing out to try some fatties with....so guess that will tell us all we need to know in a way since JR's first post was over fatties to begin with :D
post #20 of 44

Re: Strange taste with new smoker, HELP!!!

okay, 6:30 am....got the masterbuilt all fired up and ready with the wally world chips.....she is a smoking, weather is typical seattle...raining...but I've got the butterfly umbrella up to protect my smoker!!!. Loaded her up with 3 fatties....2 jd hot and one jd sage......lets see what happens.......

an additonal goodie is my new grinder from LEM is out for delivery today and should have her later this evening....so I'm stoked to get a new toy as well :D
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Electric Smokers
SmokingMeatForums.com › Forums › Smoking Supplies & Equipment › Electric Smokers › Strange taste with new smoker, HELP!!!